pg.rb:14:in `require': cannot load such file -- 2.1/pg_ext (LoadError)

Issue #193 resolved
recursivehook
created an issue

Been fighting with the following:

C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:14:in `require': cannot load such file -- 2.1/pg_ext (LoadError)
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:14:in `rescue in <top (required)>'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:3:in `<top (required)>'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:76:in `require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:72:in `each'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:72:in `block in require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:61:in `each'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler/runtime.rb:61:in `require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.7.6/lib/bundler.rb:133:in `require'
        from W:/MyApp/MyTestApp/config/application.rb:7:in `<top (required)>'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands/commands_tasks.rb:79:in `require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands/commands_tasks.rb:79:in `block in server'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands/commands_tasks.rb:76:in `tap'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands/commands_tasks.rb:76:in `server'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands/commands_tasks.rb:40:in `run_command!'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.1.8/lib/rails/commands.rb:17:in `<top (required)>'
        from bin/rails:8:in `require'
        from bin/rails:8:in `<main>'

Have tried every SO and bitbucket article I could find that was potentially related, as well as quite a few other random potential solutions and none have had any success. (A bit frustrating)

Here is my environment/stack:

  • Windows 8.1 x64
  • PostgreSQL 9.3
  • Uru
  • RubyInstaller Ruby 2.1.5-p273 x64
  • Heroku App
  • bundle install (rails, pg, etc...) for gems

Have also tried circumventing the Heroku portion, as well as building natively, different versions of pg, different versions of postgresql, different bit versions of ruby, using gem install instead of bundle, et cetera...

Any assistance would be GREATLY appreciated! Thanks.

Comments (9)

  1. Ryan Condron

    I also am working in a Windows environment, I am having the same issue with the 0.18.0 release, but the last release of the 0.18.0 version installs fine. Still may be an issue.

  2. Log in to comment