PostgreSQL 9.6 (incompatible library)

Issue #254 invalid
Lucas Caton
created an issue
ActiveRecord::StatementInvalid:
  PG::InternalError: ERROR:  incompatible library "/usr/local/lib/postgresql/uuid-ossp.so": version mismatch
  DETAIL:  Server is version 9.5, library is version 9.6.

My stack:

  • Ruby 2.3.2
  • pg gem 0.19.0

Comments (2)

  1. Lars Kanis

    Sorry for the late response, but it looks like the PostgreSQL contrib package on the server has a different version than PostgreSQL server itself. For sure it's not a pg, but a server side issue, so I'm closing the ticket.

  2. Log in to comment