Issue #4 resolved

supply PGconn::VERSION constant or similar

Michael Granger
repo owner created an issue

Via Mike Pomraning in [[|Rubyforge feature request 27161]]:

It'd be quite useful to programmatically determine ruby-pg's version, so that one could apply conditional monkeypatches as needed to older versions of the library.

{{{PGconn::VERSION}}} would be great!

Comments (1)

  1. Michael Granger reporter

    New build system, build with rake-compiler, added PGconn::VERSION.

    • Replaced the existing Rakefile with a small core set of tasks and task libraries under rake/.
    • Added a PGconn::VERSION constant (closes #4).
    • Replaced the ARCHFLAGS warning under Darwin with code to duplicate the archflags Postgres was compiled with.


  2. Log in to comment