Issue #90 resolved

Unable to load pg (require 'pg' failed)

eljumbo
created an issue

Hi,

I work on :

Windows XP SP3

PostgreSQL 9.1

ruby 1.9.3p0 (2011-10-30) [i386-mingw32]

pg (0.11.0)

I have installed all the stuff without problems, but when I want to launch a script to test the database connection I expect this problem :

P:>ruby C:\myscript.rb C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in require': cannot load such file -- 1.9/pg_ext (Loa dError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire' from C:/Ruby193/lib/ruby/gems/1.9.1/gems/pg-0.11.0/lib/pg.rb:10:in rescue in <top (required)>' from C:/Ruby193/lib/ruby/gems/1.9.1/gems/pg-0.11.0/lib/pg.rb:3:in<top (required)>' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in require' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:inrescue in require' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in require' from C:/myscript.rb:3:in<main>'

Also a dialog box appears telling me that the LIBPQ.DLL can't be found...

I can't found any solution to that ... Hope you can help me !

Romain <eljumbo> G.

Comments (1)

  1. Log in to comment