Commits

Anonymous committed f1a42d6

Implicitly require the Sequel core_extensions plugin.

  • Participants
  • Parent commits b5bb56b

Comments (0)

Files changed (2)

 	self.dependency 'loggability', '~> 0.4'
 
 	self.dependency 'rspec', '~> 2.8', :developer
-	self.dependency 'sequel', '~> 3.38', :developer
+	self.dependency 'sequel', '>= 3.38', :developer
 
 	self.spec_extras[:licenses] = ["BSD"]
 	self.spec_extras[:post_install_message] = [

lib/treequel/sequel_integration.rb

 
 begin
 	require 'sequel'
+	Sequel.extension( :core_extensions )
+
 rescue LoadError => err
 	Treequel.logger.info "Sequel library didn't load: %s: %s" % [ err.class.name, err.message ]
 	Treequel.logger.debug "  " + err.backtrace.join( "\n  " )