queues not visible with ActiveMQ 5.13

Create issue
Issue #27 new
Former user created an issue

Hello,

With the message manager 3.0 trying to connect to ActiveMQ 5.13.3. The activemq-all jar we have added to the classpath, then activate profile. Next filled in the JMX service url (ip) and connect. It seems that there is a connection, although the queues are not visible

When i make a connection with jconsole, with the same JMX service url, the queues are visible.

with kind regards, Renate

Comments (7)

  1. Gerco Dries repo owner

    If you are able to run the program in developer mode (run the nightly snapshot), do you see any exceptions pop up?

    Can you look in the Java Console if any messages are visible? I'll try to look at this as soon as possible, anything you can tell me would be useful.

    Thanks, Gerco.

    PS. Sent from a small device, please excuse any typos.

  2. Gerco Dries repo owner

    I tried this out with ActiveMQ 5.13.3 on Mac OS X and I can see the queues I created by sending a message to them with Message Manager. I can also see queues created by using the ActiveMQ Web console. Can you tell me more about your environment and how you created your queues?

    You do need to enable the JMX connector in activemq.xml. There is a line that reads:

    <managementContext createConnector="false"/>
    

    Change the false to true to enable the JMX connector:

    <managementContext createConnector="true"/>
    
  3. Former user Account Deleted

    sorry that it took so long to respond, there where some other issues. To answer your questions: The test we did with the nightly snapshot. There was no exception pop up. The queues are visible in:

    JConsole yes ActiveMQ webconsole yes (http://ipadres:8161/admin) SMM no

    Environment = Windows 7 en Java version:

    java version "1.8.0_102" Java(TM) SE Runtime Environment (build 1.8.0_102-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

    The jmxConnector is true

    When de broker is up, you don't see the queues and when the broker is down you get a message Connection timed out: connect

    SMM-1.JPG

    SMM-2.JPG

  4. Gerco Dries repo owner

    What kind of connectors are you exposing on the ActiveMQ broker? At the moment, Message Manager only looks for "openwire" connectors, since that's the only connector type that's guaranteed to be supported if ActiveMQ is on the classpath. If you have none of those then the broker would not appear in the combo box, as you can see above.

    Could you post the contents of the <transportConnectors> element in your ActiveMQ configuration (conf/activemq.xml)?

  5. Former user Account Deleted

    The default setting was

    <transportConnector name="activeMQ" uri="tcp://0.0.0.0:61616" />.

    By default we don't have access to the ActiveMQ confiugration as this is hosted by a software supplier. We have requested to adjust the connector to:

    <transportConnector name="openwire" uri="tcp://ipadres:61616" />

    and now it works (just like jconsole). Maybe it's an idea to put this information in your documentation?

  6. Gerco Dries repo owner

    Great, thanks for your feedback. I'll keep this bug open because this behavior is incorrect. If there is only one connector, that one should be displayed, regardless of its type.

  7. Log in to comment