Support for Solace messaging - QueueBrowser Err

Create issue
Issue #31 resolved
Sasikumar SP created an issue

Hi Gerco,

Thanks for this tool. I am testing this tool with Solace VMR community version.

I connected via SEMP over message Bus and its showing error as "Error in task Enumerating brokers". This stops me to browse any queues in the message-vpn.

Kindly please fix this bug.

Thanks, Sasi

Comments (10)

  1. Gerco Dries repo owner

    Hi Sasikumar,

    Do you get a stack trace or anything else in the dialog box? Can you send me a screenshot of the settings in your Solace profile and the settings in the connection tab?

    Thanks,

    Gerco.

    PS. Sent from a small device, please excuse any typos.

  2. Gerco Dries repo owner

    Sorry Sasi, I could not see the screen shots you attached on my phone. I will look in to this, it may be specific to the VMR community edition, I have not yet tried that particular edition. If you have access to any other Solace appliances, could you try to connect to one of those? I've been successful in connecting to VMR Enterprise and Trial editions as well as hardware Solace appliances.

    This is surely some kind of bug, any NullPointerException is - no exceptions.

    A screenshot of your profile settings and Solace API version number would be very helpful though.

  3. Gerco Dries repo owner

    I tested this with a freshly downloaded VMR community edition and it worked with some queues created in the default message vpn. I'd like to have a look at your connection settings to find out where the difference is with your setup.

  4. Sasikumar SP reporter

    Gerco,

    I have one basic question. This queue manager is for pub/sub and browse message. Why its configured with SEMP?

    As per my understanding SEMP is used to query stats and provision objects in Solace. Correct me if I am worng.

    Thanks, Sasi

  5. Gerco Dries repo owner

    Ok, I see you are using SEMP over Message Bus, let me check that with the community edition and get back to you, SEMP over HTTP worked for me so perhaps you can try that as well.

    The application uses SEMP because it needs to be able to query information that isn't possible to get via plain JMS. There is no way to get a list of message VPNs or even queues via the JMS API alone, for example.

  6. Gerco Dries repo owner

    I managed to reproduce your issue and the cause is the "Appliance Name" parameter in your settings. You have entered the IP address of the appliance there but it should be the appliance host name that is configured on the appliance itself. When you log in to the appliance on the CLI, it's the name that appears in the prompt or when you type "show hostname".

    This is required only for "SEMP Over Message Bus" due to the way that Solace works with that (the appliance hostname must be used in the topic name to send SEMP messages to), probably to allow these requests to be routed over a network of appliances.

    It's technically possible to make this application work without SEMP at all but it will require creating a user interface for manually entering Message VPN and queue names by the users. That way, SEMP can be avoided, this is not currently on my road map. Message Manager is meant to be a tool used by users with sufficient access to the system to be able to use a limited amount of SEMP.

    I do plan to support the use case of a single Message VPN without any kind of administrative access, like app developers at Northern Trust have, but haven't gotten around to that yet. A key part of being able to implement that is testing in your environment to see what is and isn't available to such users.

  7. Gerco Dries repo owner

    Hello Sasi,

    The latest nightly build has better support for limited users. Users that have no global read rights should be able to connect to their own Message VPN. The minimum requirement for using Message Manager on Solace is now that SEMP SHOW commands need to be enabled at the message-vpn level.

  8. Log in to comment