Overview

README: PETSc for Python

Author: Lisandro Dalcin
Contact: dalcinl@gmail.com
Web Site:http://petsc4py.googlecode.com/
Organization: CIMEC <http://www.cimec.org.ar/>
Address:
CCT CONICET, 3000 Santa Fe, Argentina

Thank you for downloading the PETSc for Python project archive. As this is a work in progress, please check the project website for updates.

  • To build and install this package, you must meet the following requirements.
    • PETSc 3.3 or 3.2, built with shared libraries (i.e., by passing --with-shared-libraries option to PETSc configure script; this is not strictly required, but highly recommended).
    • Python 2.4 to 2.7 and 3.1 to 3.2.
    • NumPy 1.0.1 and above.
  • This package uses standard distutils. For detailed instructions about requirements and the building/install process, read the file docs/srouce/install.rst.