Commits

Emile Anclin  committed 942136d

preparte version 0.23.0

  • Participants
  • Parent commits c9fd955

Comments (0)

Files changed (4)

 ChangeLog for PyLint
 ====================
 
+2010-12-16 -- 0.23.0
+
+   * documentation: update, add manpages
+   * performance: several improvements
+   * python3: finalize python3 support
+
+   * W0106: new warning 'Expression "%s" is assigned to nothing'
+
    * drop E0501 and E0502 messages about wrong source encoding: not anymore
      interesting since it's a syntax error for python >= 2.5 and we now only
      support this python version and above.

File __pkginfo__.py

 
 modname = distname = 'pylint'
 
-numversion = (0, 22, 0)
+numversion = (0, 23, 0)
 version = '.'.join([str(num) for num in numversion])
 
-install_requires = ['logilab-common >= 0.53.0', 'logilab-astng >= 0.21.0']
+install_requires = ['logilab-common >= 0.53.0', 'logilab-astng >= 0.21.1']
 
 license = 'GPL'
 copyright = 'Logilab S.A.'

File debian/changelog

+pylint (0.23.0-1) unstable; urgency=low
+
+  * new upstream release
+
+ -- Émile Anclin <emile.anclin@logilab.fr>  Thu, 16 Dec 2010 14:38:44 +0100
+
 pylint (0.22.0-1) unstable; urgency=low
 
   * new upstream release

File debian/control

 
 Package: pylint
 Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0), python-logilab-astng (>= 0.21.0)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0), python-logilab-astng (>= 0.21.1)
 Suggests: python-tk
 XB-Python-Version: ${python:Versions}
 Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test