Issue #7 resolved

sage-buffer variable is void

MaksimZh
created an issue

When I run "M-x run-sage" I see the following error message:

"Symbol's value as variable is void: sage-buffer"

It looks like it is caused by (null sage-buffer) operator at line 560 in sage-mode.el.

https://bitbucket.org/gvol/sage-mode/src/484316bce34e/emacs/sage-mode.el#cl-560

Comments (8)

  1. Ivan Andrus repo owner

    Thanks for the bug report. I know it's a lot of work to write and respond.

    Unfortunately I can't reproduce this on my machine. Perhaps you can try reinstalling the latest spkg (I just updated it a few seconds ago) with

    sage -f 'http://boxen.math.washington.edu/home/iandrus/sage_mode-0.8.spkg'
    

    and then running with

    emacs -Q -L "/home/maksim/Applications/sage/data/emacs" -l sage
    

    and then

    M-x run-sage
    

    That will rule out anything in your .emacs causing the problem. Otherwise running

    M-: (setq sage-buffer nil)
    M-x run-sage
    

    might tell us if there is another problem.

  2. MaksimZh reporter

    Following your instructions, I've found out that sage-mode conflicts with ergoemacs. If I disable ergoemacs load everything works.

  3. MaksimZh reporter

    Actually Ergoemacs contains old versions of python-related packages inside. Even though it does not load them explicitly, it adjusts load-path variable and makes Emacs use wrong versions. The problem has been solved by [re]moving the following files:

    ~/.emacs.d/ergoemacs_1.9.3.1/packages/python.el
    ~/.emacs.d/ergoemacs_1.9.3.1/packages/python.elc
    ~/.emacs.d/ergoemacs_1.9.3.1/packages/python-mode.el
    ~/.emacs.d/ergoemacs_1.9.3.1/packages/python-mode.elc
    
  4. Ivan Andrus repo owner

    Ah. Okay. It looks like it's using an old version of fgallina's. When fgallina first wrote it he didn't care about backward compatibility, but now it's going to be included with Emacs 24.2 so he's making it backwards compatible. I'm currently working on supporting his new version since there are still some differences.

    I'm glad you found the problem.

  5. Log in to comment