Source

hbbackend / ivy.xml

Full commit
<ivy-module version="2.0">
    <info organisation="org.honeynet" module="hbbackend"/>

    <configurations>
      <conf name="build"/>
      <!-- <conf name="buildlib"/> -->
    </configurations>

    <dependencies>
      <dependency org="javax" name="javaee-api" rev="6.0" conf="build->default" transitive="false"/>
      <dependency org="org.osgi" name="org.osgi.core" rev="4.2.0" conf="build->default" transitive="false"/>
      <dependency org="org.osgi" name="org.osgi.compendium" rev="4.2.0" conf="build->default" transitive="false"/>
      <dependency org="org.osgi" name="org.osgi.enterprise" rev="4.2.0" conf="build->default" transitive="false"/>

      <dependency org="org.slf4j" name="slf4j-api" rev="1.6.1" conf="build->default" transitive="false"/>
      <dependency org="ch.qos.logback" name="logback-core" rev="0.9.28" conf="build->default" transitive="false"/>
      <dependency org="ch.qos.logback" name="logback-classic" rev="0.9.28" conf="build->default" transitive="false"/>
      <!-- <dependency org="org.slf4j" name="slf4j-jdk14" rev="1.6.1" conf="build->default" transitive="false"/> -->

      <dependency org="postgresql" name="postgresql" rev="9.0-801.jdbc4" conf="build->default" transitive="false"/>

      <dependency org="net.java.xadisk" name="xadisk" rev="1.1" conf="build->default" transitive="false">
	<artifact name="xadisk" type="jar"/>
	<artifact name="xadisk" type="rar"/>
      </dependency>

      <dependency org="org.codehaus.jackson" name="jackson-core-asl" rev="1.7.1" conf="build->default" transitive="false"/>
      <dependency org="org.codehaus.jackson" name="jackson-mapper-asl" rev="1.7.1" conf="build->default" transitive="false"/>

      <dependency org="com.googlecode.concurrentlinkedhashmap" name="concurrentlinkedhashmap-lru" rev="1.2" conf="build->default" transitive="false"/>

      <dependency org="rhino" name="js" rev="1.7R2" conf="build->default" transitive="false"/>

      <!-- <dependency org="org.codehaus.groovy" name="groovy-all" rev="1.8.0" conf="build->default" transitive="false"/> -->
      <!-- <dependency org="org.fusesource.jansi" name="jansi" rev="1.2.1" conf="build->default" transitive="false"/> -->
      <!-- <dependency org="jline" name="jline" rev="0.9.94" conf="build->default" transitive="false"/> -->
      <!-- <dependency org="commons-fileupload" name="commons-fileupload" rev="1.1.1" conf="build->default" transitive="false"/> -->

      <!-- <dependency org="org.glassfish.grizzly" name="grizzly-framework" rev="2.1.1" conf="build->default" transitive="false"> -->
      <!-- 	<artifact name="grizzly-framework" type="jar"/> -->
      <!-- 	<artifact name="grizzly-framework" type="sources" ext="jar"/> -->
      <!-- </dependency> -->
      <!-- <dependency org="org.glassfish.grizzly" name="grizzly-http" rev="2.1.1" conf="build->default" transitive="false"> -->
      <!-- 	<artifact name="grizzly-http" type="jar"/> -->
      <!-- 	<artifact name="grizzly-http" type="sources" ext="jar"/> -->
      <!-- </dependency> -->
      <!-- <dependency org="org.glassfish.grizzly" name="grizzly-http-server" rev="2.1.1" conf="build->default" transitive="false"> -->
      <!-- 	<artifact name="grizzly-http-server" type="jar"/> -->
      <!-- 	<artifact name="grizzly-http-server" type="sources" ext="jar"/> -->
      <!-- </dependency> -->
      <!-- <dependency org="org.glassfish.grizzly" name="grizzly-rcm" rev="2.1.1" conf="build->default" transitive="false"> -->
      <!-- 	<artifact name="grizzly-rcm" type="jar"/> -->
      <!-- </dependency> -->
      <!-- <dependency org="org.glassfish.grizzly" name="grizzly-http-server-multipart" rev="2.1.1" conf="build->default" transitive="false"> -->
      <!-- 	<artifact name="grizzly-http-server-multipart" type="jar"/> -->
      <!-- 	<artifact name="grizzly-http-server-multipart" type="sources" ext="jar"/> -->
      <!-- </dependency> -->
      <!-- <dependency org="org.glassfish.gmbal" name="gmbal-api-only" rev="3.1.0-b001" conf="build->default" transitive="false"/> -->

      <!-- <dependency org="org.springframework" name="org.springframework.core" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.springframework" name="org.springframework.context" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.springframework" name="org.springframework.beans" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.springframework" name="org.springframework.expression" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.springframework" name="org.springframework.asm" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->

      <!-- <dependency org="org.springframework" name="org.springframework.aop" rev="3.0.5.RELEASE" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.aopalliance" name="com.springsource.org.aopalliance" rev="1.0.0" conf="build->runtime" transitive="false"/> -->
      <!-- <dependency org="org.eclipse.gemini.blueprint" name="gemini-blueprint-core" rev="1.0.0.M1" conf="build->default" transitive="false"/> -->
      <!-- <dependency org="org.eclipse.gemini.blueprint" name="gemini-blueprint-extender" rev="1.0.0.M1" conf="build->default" transitive="false"/> -->
      <!-- <dependency org="org.eclipse.gemini.blueprint" name="gemini-blueprint-io" rev="1.0.0.M1" conf="build->default" transitive="false"/> -->

      <!-- <dependency org="com.springsource.bundlor" name="com.springsource.bundlor.ant" rev="1.0.0.RELEASE" conf="buildlib->ant" transitive="true"/> -->

      <!-- <dependency org="com.springsource.bundlor" name="com.springsource.bundlor" rev="1.0.0.RELEASE" conf="bundlor->default" transitive="false"/> -->
      <!-- <dependency org="com.springsource.bundlor" name="com.springsource.bundlor.blint" rev="1.0.0.RELEASE" conf="bundlor->default" transitive="false"/> -->

      <!-- <dependency org="org.codehaus.groovy" name="groovy" rev="1.8.0" conf="buildlib->default" transitive="false"/> -->
      <!-- <dependency org="org.codehaus.gant" name="gant_groovy1.8" rev="1.9.5" conf="buildlib->default" transitive="false"/> -->

    </dependencies>
</ivy-module>