Allow multi-line description texts

Create issue
Issue #61 resolved
Former user created an issue

Hello, I'm looking for a way to include a bulleted list in the issue description, such as:

....description:"Notify these three people * Fred * Nancy * June

Then proceed to next step" estimate:"40m" .....

Is there a way to embed a linefeed or newline inside the description text? The example above results in no description inserted at all, presumably because the line ends before the quote is closed.

Comments (40)

  1. Micha Kops repo owner

    Descriptions tend to contain more textual information .. we should definitely enable newlines in the description text.

  2. Robert Dozier

    thanks glad to see support for the idea.

    with a little trial and error I was able to get CRLF by adding double backslash in the description string. Doesnt seem possible to paste that in here, but double backslash seems to start a new line. This appears to work in the current version and jira 5.1.

    • my cool subtask / description:"This is a list \\ line two" assignee:"infsvcs_gns"
    • my other cool subtask / description:"This is a list \\ line two \\ line three" assignee:"infsvcs_gns"
  3. Micha Kops repo owner

    @rdozier Thanks for keeping me updated here! I'm glad to hear that you've found a workaround! :) Nevertheless would it be nice if the plugin allowed multiline descriptions as long as they are correctly terminated by the quotes!

  4. Kai Hermannsen

    I'd like to vote for this issue, the workaround does not really work for us: when you edit the issue again, you will see the double backslashes again - which makes it really hard to edit/update the subtasks correctly.

  5. Anon9404

    the double backslash thing doesn't seem to work for me. i'm not sure i fully understood what to do tho. i just put double backslash at the beginning of all sentences and new lines. then tried at the end of sentences and new lines. neither seemed to work. so +1 for this idea, if that means anything. or even any new working or better explained or perhaps work around posted on pastebin or something.

  6. Micha Kops repo owner

    @kaiherm @Anon9404 Thanks for your feedback! I've increased the priority of this feature request!

    Cheers

    Micha

  7. Antti Heikkinen

    I would like to have and use this feature. Is there any schedule when this could be implemented?

    I tried the double backslash, but in our jira it doesn't work. It shows the backslashes. I found the solution also from atlassian page: https://jira.atlassian.com/secure/WikiRendererHelpAction.jspa?section=all

    I'm creating "mini-projects" with this plugin and I would like to include some instructions in description field. Now it is kind of hard to read when everything is in one line.

  8. Djordje Petrovic

    Another possible workaround: Enclose the lines where you want newline characters to be acknowledged in "```" without the double quotes. The implied fixed-width font is always a plus!

  9. Kai Hermannsen

    Hello Djordje, can you give a more specific example? - I seem not be able to get it working with enclosing the lines as you suggest (I'm not sure if I understand it correctly). Thank you!

  10. Djordje Petrovic

    Make sure you're not using the proper single quotes, but the ones that are slightly tilted. The button tilde is on. Example:

    one_line
    another_line
    and_another_one
    
    Make sure the "```" markers are on separate lines themselves. Note it will also enable syntax highlighting for a language, but it doesn't look too ugly (numbers are in a different color and words like for, function etc. are made bold, if I remember correctly). newlines_in_jira_comments.PNG

  11. Kai Hermannsen

    Thank you for your effort :). - I still don't get it to work, can you please add a screenshot of the Quick Sub-Tasks screen so I can see the syntax (like in your example)?

  12. Djordje Petrovic

    It bothers me very much that no one seems to have googled "markdown newlines" and pasted a solution here.
    Just add two or more spaces at the end of your line and it will preserve the newline.
    Note that if multiple spaces are not followed by a newline in your input, they will get collapsed into a single space.

    A double <Enter> at end of line, however, yields something like a double linefeed in the output.

                      I'm not sure how to produce indentation without this code-box, however.
    
  13. Djordje Petrovic

    Am not sure about "Quick Sub-Tasks screen". (I don't even know what that is.)
    I thought this issue was about newlines in issue descriptions?

  14. Djordje Petrovic

    I see. The URL to this page contains "jira-quick-subtasks".
    I apologize for any misleading information from my side and excuse my ignorance.

  15. Antti Heikkinen

    I tried with tilde (') and in sample screen it has desired effect but when I try to create subtasks with plugin with '-marks all descriptions are left empty. So does not work.

    Could this please be fixed? As I'm no developer this sounds as a small problem as Jira supports tilde(because of sample screen, the screen where I create the templates)?

  16. Antti Heikkinen

    Is this going to be implemented? Any schedule? Our sub-task design requires a lot of "comments" on desc.field so tasks are not readable without line changes.

  17. Antti Heikkinen

    What ever is easiest to implement. \n is ok because I think there will never be any need for those words in text... Or how about Subtask / description:"We" \n "want "\n*" this" Just one idea, and I have no idea is this possible to implement.

    Do you have any schedule or timeframe for update with multiline desc?

  18. Antti Heikkinen

    Thanks Micha! Waiting for release 4.0! Any schedule when 4.0 is out? Or is there any way to already start using "4.0 beta"?

  19. Micha Kops repo owner

    @anagonda If you don't find any issue with the provided version, I'd publish the new release on the marketplace today or tomorrow.

  20. Antti Heikkinen

    multilinetest.pngHi, we just got the Alpha version in our test jira. I have one problem. I cannot create multi-subtasks. The button "Create Sub-Tasks" does nothing. The create pop-up screen just hangs there and nothing. I just asked our jira-admin to check if there is any errors generated.

    Our jira version is 6.2.5.

  21. Micha Kops repo owner

    @anagonda Oh, I'm sorry! At the moment, the new version is compatible with JIRA 7.0- 7.0.10. Compatability for versions below was originally planned for an upcoming release (4.1.0). But nevertheless thanks very much for your time here! Sorry that I didn't point out this requirement earlier :)

  22. Log in to comment