Commits

Victor Stinner committed 416f68e

fix setup.py: don't use with statement to stay compatible with python 2.4

set version to 1.3.3; update changelog

  • Participants
  • Parent commits f89650d

Comments (0)

Files changed (3)

hachoir-parser/ChangeLog

-hachoir-parser 1.3.2
+hachoir-parser 1.3.3
 ====================
 
+ * fix setup.py: don't use with statement to stay compatible with python 2.4
+
+hachoir-parser 1.3.2 (2010-03-01)
+=================================
+
  * Include the README file in the tarball
  * setup.py reads the README file instead of using README.py to break the
    build dependency on hachoir-core

hachoir-parser/hachoir_parser/version.py

-__version__ = "1.3.2"
+__version__ = "1.3.3"
 PACKAGE = "hachoir-parser"
 WEBSITE = "http://bitbucket.org/haypo/hachoir/wiki/hachoir-parser"
 LICENSE = 'GNU GPL v2'

hachoir-parser/setup.py

 #!/usr/bin/env python
-from __future__ import with_statement
 from imp import load_source
 from os import path
 from sys import argv
     for name in MODULES:
         PACKAGES["hachoir_parser." + name] = "hachoir_parser/" + name
 
-    with open('README') as readme:
-        long_description = readme.read()
+    readme = open('README')
+    long_description = readme.read()
+    readme.close()
 
     install_options = {
         "name": hachoir_parser.PACKAGE,