Commits

Anonymous committed 59e515f

hachoir-parser: cleanup changelog, set dependency on hachoir-core 1.0.1, set version to 1.0 (!)

Comments (0)

Files changed (3)

hachoir-parser/ChangeLog

 Changes:
 
  * OLE2: Support file bigger than 6 MB (support many DIFAT blocks)
- * OLE2: Add ".msi" file extension
  * OLE2: Add createContentSize() to guess content size
- * OLE2: Fix to support documents generated on Mac
- * LNK: Improve parser a lot
+ * LNK: Improve parser (now able to parse the whole file)
+ * EXE PE: Add more subsystem names
+ * PYC: Support Python 2.5c2
  * Fix many spelling mistakes
- * EXE PE: Add more subsystem names
- * PYC: Support new version (2.5c2), fix long integer parser (support
-   negative number), add (disabled) code to disassemble bytecode, use
-   self.code_info to avoid replacing self.info
 
 Minor changes:
 
+ * PYC: Fix long integer parser (negative number), add (disabled) code
+   to disassemble bytecode, use self.code_info to avoid replacing self.info
+ * OLE2: Add ".msi" file extension
+ * OLE2: Fix to support documents generated on Mac
  * EXIF: set max IFD entry count to 1000 (instead of 200)
  * EXIF: don't limit BYTE/UNDEFINED IFD entry count
  * EXIF: add "User comment" tag

hachoir-parser/hachoir_parser/version.py

-__version__ = "0.10.0"
+__version__ = "1.0"
 PACKAGE = "hachoir-parser"
 WEBSITE = "http://hachoir.org/wiki/hachoir-parser"
 LICENSE = 'GNU GPL v2'

hachoir-parser/setup.py

         "package_dir": PACKAGES,
     }
     if use_setuptools:
-        install_options["install_requires"] = "hachoir-core>=1.0"
+        install_options["install_requires"] = "hachoir-core>=1.0.1"
         install_options["zip_safe"] = True
     setup(**install_options)