1. Hideo Hattori
  2. pgmagick
  3. Issues
Issue #32 resolved

pgmagick install error

Anonymous created an issue

os centos 6 i386 installed: python 3.2.3 Package boost-1.41.0-11.el6_1.2.i686 Package boost-devel-1.41.0-11.el6_1.2.i686 Package GraphicsMagick-1.3.16-5.el5.i386 Package GraphicsMagick-c++-1.3.16-5.el5.i386 Package GraphicsMagick-devel-1.3.16-5.el5.i386 Package GraphicsMagick-c++-devel-1.3.16-5.el5.i386

pip install pgmagick got error

{{{

!python

pip install pgmagick Downloading/unpacking pgmagick Running setup.py egg_info for package pgmagick include header path: /usr/include/GraphicsMagick/ library path: /usr/lib/libGraphicsMagick++ GraphicsMagick version: 1.3.16 Traceback (most recent call last): File "<string>", line 16, in <module> File "/tmp/pip-build/pgmagick/setup.py", line 116, in <module> if len(_version) == 2: TypeError: object of type 'map' has no len() Complete output from command python setup.py egg_info: include header path: /usr/include/GraphicsMagick/

library path: /usr/lib/libGraphicsMagick++

GraphicsMagick version: 1.3.16

Traceback (most recent call last):

File "<string>", line 16, in <module>

File "/tmp/pip-build/pgmagick/setup.py", line 116, in <module>

if len(_version) == 2:

TypeError: object of type 'map' has no len()


Command python setup.py egg_info failed with error code 1 in /tmp/pip-build/pgmagick Storing complete log in /root/.pip/pip.log

}}}

Comments (2)

  1. Log in to comment