Issues

Issue #100 wontfix

Old distribute version makes pudb uninstallable

Laurens Van Houtven
created an issue

Hi :)

I've ran into an issue installing pudb into the tox virtualenv which I believe to be a consequence of pudb requriing distribute >= 0.6.35, with tox installing distribute == 0.6.34. Here's an excerpt:

Downloading/unpacking pudb (from -r /Users/lvh/Code/exponent/requirements-testing.txt (line 3))
  Using version 2013.1 (newest of versions: 2013.1, 2012.3, 2012.2.1, 2012.2, 2012.1, 2011.3.1, 2011.3, 2011.2, 2011.1, 0.93.1, 0.93, 0.92.15, 0.92.14, 0.92.13, 0.92.12, 0.92.11, 0.92.10, 0.92.9, 0.92.8, 0.92.7, 0.92.6, 0.92.5, 0.92.4, 0.92.3, 0.92.2, 0.92.1, 0.92, 0.91.5, 0.91.4, 0.91.3, 0.91.2, 0.91.1, 0.91, 0.90.6, 0.90.5, 0.90.4, 0.90.3, 0.90.2, 0.90.1, 0.90)
  Using download cache from /Users/lvh/.pip/cache/https%3A%2F%2Fpypi.python.org%2Fpackages%2Fsource%2Fp%2Fpudb%2Fpudb-2013.1.tar.gz
  Running setup.py egg_info for package pudb
    The required version of distribute (>=0.6.35) is not available,
    and can't be installed while this script is running. Please
    install a more recent version first, using
    'easy_install -U distribute'.

    (Currently using distribute 0.6.34 (/Users/lvh/Code/exponent/.tox/pypy/site-packages/distribute-0.6.34-py2.7.egg))
    Complete output from command python setup.py egg_info:
    The required version of distribute (>=0.6.35) is not available,

and can't be installed while this script is running. Please

install a more recent version first, using

'easy_install -U distribute'.

I've fixed this by adding a pip install --upgrade distribute line right before attempting to install that, but I'm guessing the appropriate thing would be for tox to install the latest version of distribute instead?

Comments (3)

  1. Laurens Van Houtven reporter

    Hi Holger

    ~  tox --version && python -c "import setuptools; print setuptools.__version__"
    1.4.3 imported from /usr/local/Cellar/python/2.7.2/lib/python2.7/site-packages/tox/__init__.pyc
    0.6
    

    setuptools/distribute doesn't appear to provide minor versions in its version? pip install --upgrade distribute finds 0.6.39, but keeps reinstalling 0.6.40 (successfully) -- I don't know if that's a bug in the package or something going awry on my machine. Either way this is way newer than the distribute being installed and newer than the one pudb requires :)

    virtualenv version if it matters:

    ~  python -c "import virtualenv; print virtualenv.__version__"
    1.9.1
    
  2. Log in to comment