Currently 0.6.19 is required, but 0.6.21 has been released upstream. If tox can't be made to use whatever the latest is, it should at least be updated to 0.6.21.
Following this now that I've logged it. I reported the bug.
In the mean time 0.6.24 is releases as well. My tests won't run because an indirect dependency of my code requires at least version 0.6.21
It would be very nice if we could choose/configure which version of distribute to use. Right now the install script is hardcoded in BASE64-encoding in virtualenv.py, making it virtually impossible to swap for a newer version.