Remove the --pre pip option by default

Issue #193 on hold
Dario Bertini created an issue

This can break some builds

I looked at the Changelog for when this change was introduced, and apparently pip would refuse to install the exactly specified prerelease dependencies unless the --pre flag was supplied

Also the default [py25] environment modifies the
 default installer_command (new config option) to use pip without the "--pre" 
 which was introduced with pip-1.4 and is required if you want to install non-stable releases.
 (tox defaults to install with "--pre" otherwise).

This is understandable, but apparently it's not the case anymore, since if you run pip install coverage==4.0a1 it will install the package without making a fuss

I don't know when pip changed its behavior, but it'd be nice to take it into account now

Comments (7)

  1. Holger Krekel repo owner

    if i do pip install >=1.4.0.dev1 does it effectively mean pip install --pre >=1.4.0.dev1?

  2. Donald Stufft

    Sort of? pip install foobar>=1.4.0.dev1 would enable --pre only for foobar, not for the dependency foobar has on other-thing>=1.0 (unless of course the dependency was other-thing>=1.0.dev1.

  3. Chris Withers

    I'll second the voices in Ned's posting: please remove --pre, it creates unpleasant breakage...

  4. Log in to comment