tox doesn't work with pyrun

Issue #227 on hold
Marc-Andre Lemburg created an issue

When running tox, it sets up a virtualenv using the command line:

<python-interpreter> -mvirtualenv --setuptools --python <path-to-py27-bin> py27

This works with CPython, but is not really in line with the documented use of the -m option:

-m mod : run library module as a script (terminates option list)

pyrun uses a different command line parser, since it has to emulate the CPython in Python and does not know how to handle options which use arguments without separating space.

Could this be changed to use "-m virtualenv" instead, to be in line with the Python documentation ?

Comments (5)

  1. Marc-Andre Lemburg reporter

    Thanks, Holger. It works now :-)

    Aside: I ran into this while trying to check a user error report for installing egenix-mx-base using tox. This gives intermittent installation errors, which I've not seen anywhere else. I'm still investigating this, since I'm not sure whether it's caused by the tox virtualenv setup or our web installer on PyPI.

  2. Log in to comment