tox 1.9.1 ignores package versions specified in requirements.txt files

Issue #230 on hold
Mikhail Korobov created an issue

Hi,

It seems that tox 1.9.1 ignores package versions specified in included requirements files, and installs latest package versions instead. 1.9.0 works fine. This broke e.g. Scrapy tests.

[testenv]
deps =
    -r requirements.txt

requirements.txt:

foo == 1.0.0

Check e.g. https://travis-ci.org/scrapy/scrapy/jobs/55483601 - it has

precise installdeps: pyOpenSSL==0.13, lxml==2.3.2, Twisted==11.1.0, boto==2.2.2, Pillow<2.0, django==1.3.1, cssselect==0.9.1, zope.interface==3.6.1, mock, mitmproxy, netlib, pytest-twisted

line, but mitmproxy is specified as mitmproxy==0.10.1 in https://github.com/scrapy/scrapy/blob/master/tests/requirements.txt file.

Comments (4)

  1. Holger Krekel repo owner
    • backout ability that --force-deps substitutes name/versions in requirement files due to various issues.

    • This fixes issue228, fixes issue230, fixes issue231 which popped up with 1.9.1.

    • bump to 1.9.2 version

    → <<cset 452288d6c500>>

  2. Log in to comment