Python 2.4 not working with Virtualenv 1.8

Issue #56 on hold
Gustavo Picón created an issue

Tox requires 'virtualenv>=1.7', but virtualenv 1.8 dropped Python 2.4 support. Installing 'tox' in a clean environment, and letting easy_install/pip install virtualenv, will install venv 1.8, so tests on Python 2.4 will fail.

This can be solved by changing the dependency to 'virtualenv>=1.7,<1.8'.

Comments (6)

  1. Holger Krekel repo owner

    Question is if virtualenv1.8 and subsequent releases are/will be critical to other issues (for example 3.3 support). At the moment i'd rather leave it as is to give the user a choice - maybe display a note/hint when creating a py2.4 env with a virtualenv fails.

  2. Log in to comment