Unconditional argparse dependency

Issue #5 on hold
Anonymous created an issue

{{{setup.py}}} unconditionally depends on {{{argparse}}}, which is included as of Python 2.7 and 3.2. In order to package tox cleanly, this dependency has to be patched out if the system python is 2.7 or 3.2.

The attached changeset includes the {{{argparse}}} dependency only when required (on Python < 2.6 or on Python 3.0 and 3.1).