1. Holger Krekel
  2. tox
  3. Issues

Issues

Issue #98 on hold

Cannot build python 2.4 configurations

vmalloc
created an issue

When having a new Python installed, tox attempts to run virtualenv from where it finds it. Recent version of virtualenv require python 2.5 and newer, which causes the virtualenv creation to fail.

Is Python 2.4 supported by tox?

Comments (6)

  1. Holger Krekel repo owner

    it requires a virtualenv version that only supports python2.5 and onwards. Feel free to do some testing if relaxing this requirement would still pass the tox tests and submit a pull request for changing it.

  2. Giampaolo Rodola

    I think tox is exactly that kind of tool which needs to support older python versions such as 2.4 and 2.5. There are plenty of packages out there still supporting those versions (especially zope/plone related ones). For instance, I do for psutil, pysendfile and pyftpdlib projects, from 2.4 to 3.4 by using a single code base. Probably tox shouldn't support them "out of the box" but if the user takes care of installing all the necessary deps similarly to what suggested by Richard, then tox should be able to support them. That said, Richard suggestion didn't work for me:

    ERROR:   py24: UnsupportedInterpreter: python2.5 is not supported anymore, sorry
    
  3. Log in to comment