Canon 550d Error 80 (err 80)

Issue #1056 resolved
Former user created an issue

I have used ML (ver. 2011.11.11.) since November. It worked properly since November. But today I cannot turn on my camera. The error message is: Err 80. What can I do to resolve problem?

Comments (14)

  1. Former user Account Deleted

    I tried without card. Same error. Message is in viewfinder only. And I tried to turn on with another SD card (ML 2011.11.11. on it) and LED flashes TWICE.

    I think the issue is the same as MTG wrote it earlier. After using the camera during the day I switched it off. Later on I went to download the photos so switched it on and that's when I found the problem.

    1. After reseating the battery and memory card I power on. 2. Nothing happening in screen or VF. 3. Press shutter button and in VF it flashes "Busy" and I see the ISO and exposure values changing. 4. Nothing much else happens if I start pressing other buttons eventually I get "Err 80"

  2. Former user Account Deleted

    I tried to turn on pushing the shutter button:

    - the LED flashes twice - the autofocus works - I can change ISO

    But it takes only a few seconds (3-4) than the "Error 80" occurs. The screen does not work. I see values only in the viewfinder.

  3. Alex

    Not sure if it helps... but maybe it's worth checking this: http://www.dvxuser.com/V6/showthread.php?274188-I-did-a-bad-thing&p=2527639&viewfull=1#post2527639

    If you start the camera with ML, the LED flashes twice and then it has the same symptoms, right? (AF working etc).

    Load this autoexec, and it should do the following:

    • you should hear a beep
    • card LED will turn on for a few seconds
    • after it turns off, you'll find a diagnostic log on the card (LOGxxx.LOG). Attach that file here.
  4. Alex

    Try this one - it should make the LED blink continuously.

    EOSCard was setup for Magic Lantern, right?

    Also, can you tell me what were you doing last time before it stopped working? (what ML functions you have used, how you have turned off the camera...)

  5. Former user Account Deleted

    I tried this new autoexec.bin but the LED flashes only twice and not continuously. (And yes, the SD card was formatted for Magic Lantern.) Last time I took some photos, and finally I turned off my camera. Magic Zoom was turned on but I did not modify ML setup during this session.

  6. Former user Account Deleted

    The autofucos works 3-4 seconds and a green point is blinking in the viewfinder. Aperture value is visible too. Finally it stops to work and "Err 80" is blinking.

  7. Alex

    This means Magic Lantern is not being loaded. Can you check if the card with LED blinking (the small autoexec) works in another camera (just to be sure the card is prepared correctly)? Any camera with ML installed will work with the blinking autoexec.

    Could be a problem with the card slot?

    Were you able to download the photos you took last time?

    If ML doesn't load, I'm sorry, but I can't do any further troubleshooting. It is possible that the problem happens at bootloading stage (before loading the main firmware). Autofocus and viewfinder info are handled by a second CPU (we don't have access to it) and on 550D they do work even if the bootloader gets stuck.

  8. Former user Account Deleted

    I tried two SD cards. Same error. But it was able to download pictures (with an SD card reader) last time. Now I cannot try this autoexec.bin with another 550d.

    I have bought my camera 7 months ago (1 year warranty). Can I send my camera to repair with warranty to a Canon service?

  9. Alex

    Maybe. If it's not covered by warranty, they will charge you.

    The exact cause of failure is still unknown. My best guess is some problem on the SD card side, judging from the blinks. If the cards would be OK and prepared with the small autoexec, it would blink continuously - this works on any supported camera (550D, 60D, 600D, 500D, 50D, 5D) with the same autoexec.

    Just to double-check:

  10. Former user Account Deleted

    I have a 550d and the same problem. Screen stay black but if I load the autoexec.bin with the blinking light option the light is blinking and the the internal display and the autofocus is working. I have load the autoexec.bin for the diagnostic log first light flashes 2 times and than I hear a sound, but no log is created. Please help

  11. Log in to comment