Canon 600D Firmware 1.0.2

Issue #1071 duplicate
Former user created an issue

I just updated to the latest firmware for the 600D (3Ti), which is version 1.0.2 and now Magic Latern doesn't work. Is there an easy fix for this? Will be an update soon that works with this lasest firmware update? Is there anyway I can back to 1.0.1 until Magic Latern is updated? Thanks.

Comments (26)

  1. Alex

    It's already updated for 1.0.2 if you compile from source. I'm just holding back the version number until next major release.

  2. ats1995

    one question a1ex: I don't see why you are holding back newer versions? I'm eager to test them before they release, and get them as smooth as possible :P

  3. Alex

    Canon firmwares do not affect ML functionality in any way, other than changing stubs. But most users will get confused when some binaries run on 1.0.1 and others on 1.0.2.

  4. Former user Account Deleted

    Don't you think people already get confused about the fact that ML does not work with the current version of the firmware? The number of people who are asking about this and the number of people who had been told to downgrade their firmware seem to give a pretty clear indication that not releasing the update causes at least as much confusion and frustration.

    Alternatively: Could you provide information on how people call roll their own release if the source code already supports it?

    Seriously, though, I wish you would release the binaries for 1.0.2. Pretty please!

    And thank you for all your hard work on ML, this is an awesome project.

    How do people get involved? I failed to find the source code and the mailing lists thus far, and web forums are not quite the same thing.

  5. Former user Account Deleted

    Is there a use case for using an outdated firmware?

    Otherwise I would suggest to change the release process to be triggered

    • whenever there are new features
    • whenever there is a new firmware

    or both. Use of tagging should make it fairly simple to do it that way, and it would make the firmware part simple: Always use the latest.

  6. Former user Account Deleted

    @#13

    I don't think that's a kind of tone that should be used, especially in response to what seems like reasonable questions.

    With proper branching & tagging it would be a matter of 5-10 minutes for a1ex to push out a new ML for an updated firmware, which has now been available and recommended for over half a year.

    Simultaneously setting up a cross-compilation environment is non-trivial and takes some time with a much higher probability of breaking people's cameras.

    So the question "Why don't you?" makes a lot of sense, which is probably why it is being asked repeatedly.

  7. Former user Account Deleted

    Actually the .fir doesn't compile at the moment. Probably because of back end change. It fails on bmp.o with magiclantern.bin. So that is why its not trivial for him to just compile it.

  8. Former user Account Deleted

    I guess that is what the "proper branching & tagging" would have taken care of.

  9. Former user Account Deleted

    heh... dumper not compiling either... if I had dumper i'd be able to post upgrade... I can get the update.bin out just fine. But I can't combine it with the .fir file to create the 1.0.2 image.

  10. Former user Account Deleted

    I have the same problem :( A very sad day for me... New ML ver soon please!!!!!

  11. Former user Account Deleted

    Same here, I've been waiting for weeks now. While my pal with his 550D has happily been using ML all I could do is sit there and wait. Please release a new version soon, or at least announce a date! I don't care if there's barely any new features, I just wanna use ML (which has so so many great features already).

    PS: I don't really feel comfortable with compiling anything from source, I'm a filmmaker not a programmer. I definitely don't want to risk breaking my 600€-camera.

  12. One Percent

    Have a working dumper? I can post the update.bin.... or you can downgrade. The upgrade doesn't have any decent features anyway.

  13. Former user Account Deleted

    Just downgraded... I afraid Canon will release v1.0.3 when ML will support 1.0.2...

    : )

  14. One Percent

    The upgrade is not an insurmountable task.... just Alex has more pressing things ATM. If they release 1.0.3 when we have 1.0.2 we'll be able to get it up and running since the dumper will be fixed.

  15. Log in to comment