600D/T3i firmware 1.0.1 not available from Canon web site

Issue #1128 resolved
Former user created an issue

My 600D is with firmware 1.0.1. Unfortunately, this 1.0.1 lead to blinking LED when installing the ML. The links to Canon UK web site from the wiki site is dead now. Even more unfortunate for me, the vimeo.com which is said to have a mirror is blocked for my country for unknown reasons. And I do not know whether there is a way to update the Canon firmware to appropriate subversion.

Comments (22)

  1. Former user Account Deleted

    Cam says invalide firmware, when trying to downgrade with this file.I've got the 600d from amazon with 1.0.2 installed.

  2. Former user Account Deleted

    Thanks Alex. I can confirm that this problem happened to me on a new Kiss x5 (Japanese version of the 600D) that came out of the box with firmware 1.0.1 -

    I downloaded the 1.0.1 firmware link provided by Alex and successfully updated the firmware from "1.0.1--> 1.0.1"

    And now magic lantern installed no problems.

    Thanks again Alex and everyone who have worked on making this amazing unlock key to Canon's cameras!

  3. Former user Account Deleted

    @ #2

    I had no problems downgrading from 1.0.2 (pre-installed) to 1.0.1. Simply copy the above CCD11101.FIR file to the root of the SDHC card and go to the version / upgrading menu point. I cleared all settings and set the wheel on M before doing it as well as full charging the battery (a must).

  4. Former user Account Deleted

    I can´t update from firmware 1.0.1 to this 1.0.1 ¿maybe the batterie must be full charged?

  5. Former user Account Deleted

    I have updated my T3i with ML! At first it didn't work, but after updating the firmware with the file attached on top of this page, the next steps were very easy. Now, the fun part, to play with the camera and ML Software!

    Thanks a lot!

  6. Former user Account Deleted

    My T3i is not letting me downgrade to 1.0.1. It says my version (1.0.2) is up to date. I hit "cancel" and it says loading firmware update. Then it goes black and the red light blinks ominously. Not sure what to do here...I just take the battery out and do it again and its the same. Any advice??

  7. JNC

    Wow. You should try to read the ML Installation guide (This reply if for the anonymous who says the LED is blinking)

    It's not damaged. ML didn't recognize the Canon FW. Reupdate it. 1.0.1 => 1.0.1

  8. Former user Account Deleted

    What do you mean 1.0.1 to 1.0.1? I am trying to go from 1.0.2 to 1.0.1 I don't think that is covered in the guide...I need 1.0.1 for the ML but the camera won't let me downgrade. That's the problem.

  9. Former user Account Deleted

    As I've just bought an 600D to replace my 550D I had no problem downgrading the firmware from 1.0.2 to 1.0.1.

    1. format the SDHC card in your camera.
    2. move the update file on to the root of the SDHC
    3. stick it on the camera and launch the firmware update process
    4. don't press any buttons when updating! It takes a minute or two and updated neatly.

    So I didn't have any complications on this update procedure and the ML works on my 600D just as it did on my 550D!

  10. Former user Account Deleted

    i had simillar problems at first but then i updated back to 1.0.1 ... nd now its fine now

  11. Former user Account Deleted

    thank you for this :-). in french now:

    Magic lanterne ne c'est pas bien installé? lla lumière rouge clignotait et rien.. alors : Il suffit de télécharger le fichier donné par a1ex dans le premier post et RE faire l'actualisation du canon. Le mien était 1.0.1 et en le réinstallant ..plouf magic LOL. Une fois ceci de fait il suffit de reformater la carte et de réinstaller Magic Lantern. Normalement pas de clignotements et l'installe se fait en moins de 5 secondes. Voilaa. merci encore à tous les développeurs :-)

    Meltingman

  12. Former user Account Deleted

    Também estava tendo problemas para instalar o magic lantern, pois minha versão era a 1.0.2. Consegui baixar para a 1.0.1 com o arquivo que peguei aqui e deu tudo certo. Obrigado!

  13. Former user Account Deleted

    Срочно помогите подсказкой плиз, ставлю прошивку 1.0.1 Но ни где не могу найти отключение аудиокомпрессора, при съёмки с внешним микрофоном, слышно фоновое шипение....как быть?

  14. Former user Account Deleted

    my self personaly update the camea firmware from1,0,1 to 1,0,2, i did not now that it will not work the magic lantern, after a while i found this page with firmware 1,0,1, and just instaled, and after that i put the M.L. , and i was happy all is just fine, A lot of thanks from Moldova guys. soon i wil put my videos on www.videostudio.md my personal web site with results of magic lantern

  15. Former user Account Deleted

    Is it Multi-Language? I have a German Camera and the Software on it should Stay in my Language :)

  16. Former user Account Deleted

    Man, looks like I can't even copy the firmware file on the root of my SDHC card... I don't have a card reader so I let it in the camera and connect the camera to the PC, maybe that's the reason? Should I find a way to copy the firmware on the card while it's not inside the camera ? Please help!

  17. Former user Account Deleted

    Hi, when I try to downgrade my cam displays Update file error. Please check memory card and reload the battery and try again. I got full batteries and the File you uploaded. Update to 1.0.2 was succesful but now i can't downgrade :( Anybody knows a solution?

  18. Log in to comment