Issue #1142 resolved
Former user created an issue

I need to update to 2.1.1 but cannot find any links to download it ... everything it 2.1.2

Is it possible to get a copy from someone here?

Comments (9)

  1. Former user Account Deleted

    I'm trying to downgrade from 2.1.2 to 2.1.1 but not having any luck. Is it just a question of placing the new firmware on a compact flash and then going to the firmware menu in the 5dmk2? If so my 5d is not picking it up. I suspect the audio device i'm using to mount the CF onto my mac desktop might be to blame.

  2. Former user Account Deleted

    just found this been looking for it for 3 days hope it works thank you thank you thank you!

  3. Former user Account Deleted

    I still have it on my 500D. Is it the same for my model incase I have to upgrade and then downgrade again?

  4. Former user Account Deleted

    Nearly had a panic attack cause I couldn't find this anywhere...THANK YOU SO MUCH!!!

    -x-

  5. Former user Account Deleted

    I am also trying to downgrade from 2.1.2 to 2.1.1 but the firmware upgrade starts to run then I get the following message:

    Firmware update programme

    update file error. Please check the memory card and reload the battery and try again.

    Is it possible to downgrade the firmware so I can install magic lantern?

  6. Former user Account Deleted

    Thanks went from 2.1.2 to 2.1.1 with download but camera indicates "Update file cannot be found. Please check memory card and reload the battery again" Tried a couple of times. Copied all of the files in unified download to card. Not sure what's wrong...

  7. Former user Account Deleted

    Keep Trying. Had the same issue a couple of times so I removed the file from the card and then copied it over again. Worked eventually. Thanks for this.

  8. Log in to comment