550d Camera doesn't turn on

Issue #1179 wontfix
StanVid created an issue

used ml for second time with 32gb card with ml 22.12.11 install. Appeared to work ok but Canon Zoombrowser failed to download all vids. Safely removed card , reinput via same cardreader - pc message card not formatted (or something close to that) Put card back into camera and camera didn't turn on. Removed, tried with non ML card - Camera OK . Retried with same ML card - camera again didn't turn on. One additional thing of possible relevence- I have a lumix G3 as well. When I insert cardreader both canon and panasonic (photofun studio) start up and I then close down the photofun studio. Bit gutted because I appear to have lost a morning's work. I would greatly appreciate any suggestions as to what to do now - and whether there is anything I can do to prevent future occurrences. Many Thanks Stan

Comments (3)

  1. StanVid reporter

    Many thanks Alex, it was a cheap card but it had worked before with nonML camera. I will keep working with ML for the moment as (because of your efforts) it offers so much. Incidentally, I managed to retrieve most of the .mov files (as mp4s) using free software called ZAR.

  2. Log in to comment