550D and SDHC problems

Issue #1197 wontfix
sqd created an issue

Ok, so I've been trying now for a while to get ML to install, but having some issues, primarily with my SDHC card. The card I use, and have always used, is a 8GB Verbatim SDHC Class 6 card. FAT32 formatted.

First, I did everything the guide says, numerous times.

  1. Format with camera

  2. Clear settings

  3. Copy all files from the latest release to card

  4. Checked my FW version, it is the latest one.

On my first try, it froze on the "Firmware update program.. Loading" screen. Took the battery out, redid the procedure, same deal. Then I googled some, found that I could try to reinstall the latest Canon FW, even though I already had it - same thing with the Canon FW, just freezes.

So then I took an old 256mb SD-card, formatted it (FAT16), and loaded it with the ML-files - and then it took like 3 seconds to update the FW, and now it works with that card. So I put the ML-files on the 8GB card again, but then I get the "Screen is black, but autofocus works" - autoexec IS on the card, I've replaced it many times now, same deal. I've reformatted the card in windows and still nothing, I've tried FAT32 and exFat. Full format and Quick format. I've used EOScard on both cards to set it as bootable.

Tried putting in the old 256mb card again, and it works fine. Why won't it read autoexec on the 8GB card?

Comments (5)

  1. Alex

    Not sure... can you try with another 8 GB card?

    Since you say you can't run Canon's own firmware upgrade from it, the card may have some problems.

  2. sqd reporter

    Wish I could, I'd already tried it otherwise :/

    Has this not been encountered yet? Seems weird that it would only somehow have issues with booting a file.. Because otherwise I haven't had any problems with the card.

  3. Former user Account Deleted

    I have had the same problem, I just brought a brand new Sandisk Extreme Pro 95mb/s 32GB Class 10, and I can't tell you how angry iam feeling right now after 6 hours of trying, ML does not install, the screen goes blank on my 550D with firmware 1.0.9, also the camera will not update to same 1.0.9 firmware

  4. Giovanni Nanomad Condello

    Well, it's an SD card issue. You can try using a small SD card to install ML for the first time on the camera (enabling the bootflag) then EOSCard to install ML on the "bigger" card

  5. Andy Iv

    Hi Giovanni, gius,

    The same problem here. I cannot do anything with my SDHC-32. I used the EOSCard, formatted the SDHC, etc. - Even if it has just physically formatted and my 550D had native firmware it's enough to place that SDHC-32 and the problem with black screen came back. No any problems with any other SD/SDHC.

    I just don't use that SDHC awaiting for solution on the forum. Thanks.

  6. Log in to comment