50D can't format CF card

Issue #1236 invalid
Former user created an issue

Hi, I'm an enthusiast user of ml since last xmas. I've got it intstalled and fully functional on my Canon 50D, on a 4gb CF card. I use ml intensively for real estate photography (9 bracketed shots for hdr)

On January my second cf card suddenly stops working on camera (it said card not formatted).

I can read the card on my computer, and also transfer files on both directions (pc-card), but when i put it on camera, it starts on "busy" state for nearly 20 seconds, and after that it says card needs to be formatted. The problem is that when i tried to format it on camera, it can't show cards' memory size, and after pressing the button, it fails formatting.

At first, I supposed a malfunction on the cf card, so i decide to buy a new one (8gb). The same behaviour happen on this new card. No problem to read it on a pc, but the camera rejects it and can't format it.

Last test was to check those two "damaged" cards on a Canon EOS 350D:

the small 350d can read and write photographs on both cards, the old one and the new one.

After that, I tried to format the old one on the 350d, and when i switch that card to the 50d: surprise: the card is again running!!!!

Not the same luck on the new one. The same process (format on the 350d and change to the 50d) fails.

Do you think it will be some hardware problem on my 50d card's writer/reader?

Maybe a bug on ML?

Any ideas?

Thanks in advance for your help and congratulations for such a great software that makes me happy.

Pedro Ferrer Spain

Comments (1)

  1. Log in to comment