550d and sd card brick

Issue #1271 on hold
Former user created an issue

550d with magic lantern sandisk extreme 8gb 30mbs. Been filming in the early morning 2 hunters all went well. upon arrival home wanted to upload footage and suddenly does not see the card trough card reader. then put it back in camera; same problem. Now camera will only show shutter speed, iso, av. and will focus but no display and does not fire with card on board. With other card all is fine. question; Can I update Ml or will I then lose the movies on the card? It is great footage for documentary so please help! thxs Douwe

Comments (3)

  1. Alex

    Copy the contents of the card (do a disk image) and try to recover the files. Looks like the partition table was corrupted. Only format the card after you have copied all the data from it.

    I had the same problem due to a virus (at some point I've tried to download some videos on a computer which wasn't mine, and after removing the card from the reader, it was no longer recognized by the camera).

  2. Former user Account Deleted

    i had this happen before with a camera but not my canon t2i all it turned out to be was a file change that the reader made. I removed the file it added and the camera worked agian. Just compare the files on each card to find the one that was changed or added.

  3. Log in to comment