1. Trammell Hudson
  2. Magic Lantern
Issue #1473 new

600D doesn't boot without ML (was: dead after formatting)

Anonymous created an issue

hey, now it does open ONLY with the card with the autoexec.bin

(Old issue follows) hi

i've installed magic latern 2.3 sucessfully, however i wanted to restore my camera and uninstall ml

i went to the format option and i've pressed the Q button which removes also the ML from the card

when it did, i switched the camera off

thats it, it never switched on again EVER

tried pulling out the battery and the card, nothing happens it doesn't even lit the red light at the back of the camera.

dead, damn!

any solutions would be helpfull enough

Comments (25)

  1. Alex

    Hm... I don't see any logical explanation of what it happened.

    The battery and card doors are properly closed, right? If one of these is not closed (or their microswitch doesn't work), the LED may not blink at all.

    Do you see anything in viewfinder? normally it should autofocus, this function is in another CPU, not touched by ML.

  2. G. Condello

    Please run the following tests and answer: - Does your camera work [b]WITHOUT[/b] an SD card? - Does your camera work if you [b]REMOVE[/b] all the flags with EOSCard?

  3. Stelios K

    "Uhm, let me get this straight: - The camera won't boot with an SD card without the EOS_DEVELOP and BOOTDISK flags?"

    correct

    doesnt boot without the sd card doesn't boot with another sd card (flags eos_develop and bootdisk off) doesn't boot with flags eos_develop and bootdisk on and without autoexec.bin (either magic laterns either blink test autoexec.bin

    the only way to work is with an sd card which flags (flags eos_develop and bootdisk are ON) and with some autoexec.bin file in it!

  4. Alex

    I had the same problem on 550D - because the card slot was worn out, the camera thought there was something inside (even if there wasn't).

    After some attempts to bend the pins back, it started to work again.

    If it boots with autoexec.bin... I'd say just use it.

  5. Stelios K

    its not a hardware problem, it needs a combination of things, even with the same card! EOS_DEVELOP and BOOTDISK flags enabled and autoexec.bin

    if something is missing of those 3, it doesn't react.

    symptoms: the red light blinks when:

    • i insert a card with the parameteres i mentioned.
    • i take the battery out and then in again

    it doesn't blink when

    • i insert even the same card with EOS_DEVELOP off or some of the 3 parameters off
    • when taking out the battery and insert again without any card
    • when taking out the battery and insert it again with another card (formated only, as it used before the installation of ML)

    another symptom:

    when replacing the sd card from the one that contains eos_develop, bootdisk, autoexec.bin, to another that doesnt.. it doesn't blink at all. The only way the camera works is when putting the sd with the flags on and autoexec.bin and pulling out the battery completly and instert it again.

    I tried to update the firmware, i did brought back 1.0.1. Same symptoms updated to 1.0.2. Same symptoms :(

    Another symptom:

    when camera is working with the sd card with the flags and autoexec.bin, and i pull out the sd, it swiches off like the i've pulled out the battery.

    its like the SD card is a part of the camera, and can't work without.

    As being a programmer myself, the camera works with this pseudo-code:

    if EOS_DEVELOP AND BOOTDISK are enabled

      BLINK_RED_flag = true
    

    endif

    if autoexec.bin exists

      AUTOEXEC_FLAG = true
    

    endif

    if BLINK_RED_flag = true and AUTOEXEC_FLAG = true

    working_state = true

    else

    WORKING_STATE = false

    endif

    Thats the exact behavior.. and i think this code is stored somewhere and generated before the camera start and load the original firmware. its the first priority before it loads up the firmware or anything else.

  6. Stelios K

    also, when it blinks the red light once with the sd with the bootdisk eos_develop and autoexec.bin it doesn't blink when i change battery but the camera works

  7. Log in to comment