500d Exposure presets conflicting with focus patterns

Issue #1483 resolved
ats1995 created an issue

When setting focus patterns to "On", doesn't matter if the focus patterns are set to custom patterns or not, the exposure presets doesn't switch. When trying to switch, the beep sound comes and the camera auto-focus! (I use zoom out to focus.) This does only happen when the lcd is turned off by the lcd-censor. If lcd-auto off is disabled, the problem does not occur.

Comments (12)

  1. ats1995 reporter

    Haha, I didn't know you could change the focus patterns with set :D well then... that explains why you can "disable" focus patterns by setting it off. It actually is only the ability to change them with set you disable when setting focus patterns to "Off". A clearer explanation is needed in the user guide.

  2. ats1995 reporter

    I wish I was able to test it, but I don't know haw to compile (yet). If you would like some testing, an .bin is needed

  3. ats1995 reporter

    Hm, sleeping in 5 hours :( I guess I missed that part. But I never thought about changing the patterns outside of ML menu. Guess I'm not "out of the box" enough. Canon's fault^^

  4. ats1995 reporter

    That is indeed convenient. After I changed the focusing screen, I am not able to see when the focus points are turning red (unless it's really dark). So I didn't really figured out this function before the submenu was added. I guess I've got a different startingpoint: from the submenu.

  5. Log in to comment