Canon 5D mkII seems completely dead

Issue #1488 invalid
Calle_sweden created an issue

Hello, excuse my English. Ive been using ML 2.3 sucessfully for a couple of mounths but last weekend my camera didnt start. Last time i was using the camera was 2 dayes earlier when i was shooting some small jpegs, BW and coustom picture styles for GIF animations. I have latest Canon firmware installed (2.1.2). I think my problem started when i put in a third-party battery but im not sure about that. Maybe i also put in a new, never user CF-carf without ML installed. My problem now is my camera dont respond to anything. I have tried to start without card, with formated card, with card with new installed ML, without lens and with lens on the camera. The red LED dont blink at any time. Not when opening CF-door or the battery door. I have also tried the LED blink test without any blinks. What can i do?

Comments (5)

  1. Giovanni Nanomad Condello

    It looks like your only option is servicing the camera as it could be an hardware failure (no led blinking even with the test ML code -> bad)...Just make sure the battery or charger are actually working and not defective (you can go to a shop and ask them to try another battery on your camera for example)

  2. Calle_sweden reporter

    Thanks for you response. I have just charged my battery and when i put it back in the charger it switches from red to green almost instantly.

  3. ats1995

    You didn't mention it, so just to be entirely sure, you CF are made bootable? If not, make them! :)

  4. Calle_sweden reporter

    New info! I tried to put on my battery grip and the camera started! Seems to be some hardware problem with my battery door (nor original, but worked before) I was just about to send my camera to the repair but now it works just fine with or without ML. This could maybe be usefull information for someone else. Thanks for the support.

  5. Log in to comment