600D/T3i doesn't boot and light doesn't blink

Issue #1527 resolved
dollarside created an issue

T3i was working like charm with ML2.3. Last night I powered off, pulled the SD card, copied some photos (SD card content not cut, just copied), put it back in. I didn't power it on afterwards until earlier today when I found out that it won't power on at all.

Very similar to this guy's problem, but that thread didn't offer an answer: https://bitbucket.org/hudson/magic-lantern/issue/1473/600d-doesnt-boot-without-ml-was-dead-after

Here's what I see: I put in the charged battery, power on, nothing happens, no LCD, no red blinking light, no autofocus. Here is what I've tried (based on answers from everywhere): - Format card - Changed card - Recharged battery - Press set + power on - Power on in different modes - Reinstalled ML with the EOScard program - Used the "blinktest" method (not sure if I did it right, I just put the downloaded file into the root of SD card and powered on the camera) - Removed lens - Talking to my camera - Prayed

I really need this camera and any help is very very appreciated.

Comments (5)

  1. dollarside reporter

    Yes, I have tried to boot without the SD card inserted :(

    (Oops, I must have clicked twice and now I have a duplicate of this question, sorry!)

  2. dollarside reporter

    Holy cow!!! omg..

    It's 9:50 AM right now, I just tried again, and it worked!!!

    So I woke up earlier and first thing is charged my battery, just now the battery was charged, so I plugged it in, and now it works!!!!!

    First it didn't have an SD card inserted, and it says "no card" and now I inserted the card (with ML installed from earlier attempt to rescue it). I checked my camera and the Firmware version says 1.0.2, so does that mean it has some how been factory reset? I don't think ML is on the camera anymore as the usual "delete" button doesn't call up ML now.

    I want to get rid of ML first and make sure my camera is "clean" before reinstalling it again. What should I do?

    edit Now I realized there's a problem, when I turned it on, the screen was flickering. I took a few pictures to try the camera, I turned it off, back on, the flickering was gone in the menu but was photo preview was still flickering.

  3. Log in to comment