Issue #1565 invalid
Marvin P created an issue

Hello! So here is my situation,

I was on a video shoot with my t2i with Magic Lantern installed on my memory card. After a shot, we went to look over the videos on the camera. After that i turned off the camera to save my battery. 10 minutes later for our next shot, I started setting up the equipment, and put my camera on the tripod. I tried turning it on, It just stayed blank. I had 6 batteries on me and I thought it was just a dead battery... It wasn't. So in frustration i took my memory card, dumped the footage onto my laptop and formatted it.

I re-inserted the memory card and tried to turn it on and now... It still won't turn on!

It has been 2 days and I've searched the web for fixes and all that and nothing seems to work!

Weird thing is that whenever i take the battery out and put it back in and try turning the camera on, the red LED blinks three times then disappears. I could also hold onto the shutter button and it focuses for a couple seconds and then just... dies. During those crucial 3 seconds i can also see the shutter, fstop and iso inside the viewfinder.

Does anyone know what's happening to my t2i? I would like to get this fixed asap.

Comments (1)

  1. Log in to comment