Can't move focus box on 6D

Issue #1816 resolved
leandroprz created an issue

When I was using v2.3 I was able to move the focus box while on live view with the control wheel on the back of the camera. Now I tried to do that but it doesn't move like before, it's stuck.

I tested it on a 6D with ML magiclantern-v2.3.NEXT.2013Nov19.6D113

Anyone else experienced this?

Thanks

Comments (18)

  1. One Percent

    It won't move in MF unless you enable the presets, ie TL/C/BL etc, then you can use set. Also doesn't move in 1x zoom.

  2. leandroprz reporter

    Sorry, didn't know they changed the behavior of that function. Now it's working fine. Thank you

  3. leandroprz reporter
    • changed status to open

    I'm re-opening this because I recently tried the new nightly on my 60D I noticed the focus box can be moved with the control wheel on the back of the camera.

    Maybe that wasn't implemented on this camera?

  4. One Percent

    yea, its not turned off on 7D either, it just changes shape. On 6D it turns off so all you can do is manually force its coordinates with set. This would need some hack and its more of a feature request than a bug.

  5. Daniel Fort

    Yes, it applies to the 700D. I tried the workaround for the 6D and it does work though it is sluggish and of course doesn't work with the touch screen. Still, it is better than not being able to move it at all.

    I also tried the fix on the EOSM. The problem with it is that the BGMT_PRESS UP/DOWN/LEFT/RIGHT have different functions that are reassigned when the workaround takes over. I could not move the box left and right but could move it up and down, though my down (trash) button is normally set to center the box.

    Would it be possible to come up with a workaround so that the touchscreen moves the box?

  6. Alex

    Yes, it's possible, though I'm not exactly familiar with how touch screen works (e.g. what touch events are supposed to be doing in what mode, or how to tell when they don't have other function from Canon).

    I've just pushed my touchscreen experiments from last summer, when I had a 700D in my hands. Don't remember how far I've got (IIRC it worked somewhat, but had some quirks). Hope it helps.

  7. Walter Schulz

    Maybe I'm a little dense today. Please tell me what to test and how to reproduce the issue. Little vid might be helpful.

  8. Daniel Fort

    Try moving that little spot meter thingy around without a lens mounted on the camera (or a non-cpu manual lens mounted.)

    move focus box bug.jpg

  9. Walter Schulz

    Indeed. Not possible to move without lens attached.

    But 650D without lens and without ML will not show any focus box at all. More stuff not working with 650D: My - quite old - M42-lens adapter with focus confirm won't work with 650D but 7D does. I assume it has something to do with a1ex remark some while ago about Canon changing the way the cam communicates with the lens. Trap focus getting lost and other things.

  10. Log in to comment