Stressing out the shutter button leads to DSLR going crazy with Advanced Bracketing activated

Issue #1882 new
Former user created an issue

While trying out if this issue has been resolved (it hasn't) https://bitbucket.org/account/notifications/read/44744706/re-issue-1850-advanced-bracketing-with-lv-shows-last-brightest

I somehow got the DSLR taking pictures forever, some of them are being taken with the selected AB algorithm but most of the are being taken without altering the exposure times.

Abortion via scroll wheel turn is not possible when this happens, you have to turn off the camera.

It doesn't happen all the time, but mostly when you press the shutter button without "giving a damn" about the camera has focused on the scene or not (pressing shutter for effect and not waiting for the confirmation beep of the AF)

Also sometimes when this happens, the AF mode changed from AI Servo to ONE SHOT.

I can't really tell how exactly this can be produced except for trying to press the shutter button all the way through not minding about the AF.

--> http://www.youtube.com/watch?v=1OrEafjB6O4&feature=youtu.be

Camera is a EOS 550D with tonight's nightly build (February 27th)

Comments (10)

  1. One Percent

    ugh... same on 7D. It also switches to bulb mode and starts firing away. No way to stop it. Its taking 20" exposures in bright daylight... forever.

    The over/under isn't changing and draws before the histogram and raw overlays.

  2. Former user Account Deleted

    hmm mine doesn't change to Bulb but then I think maybe the length of the exposures depends on the available light.....when I tried it was obviously dark :-)

    PS & OT: Do you encounter the issues from my other linked bug report?

  3. One Percent

    maybe intervalometer is missing an ensure play or QR mode.. the other prob I'm looking for in zebra.c

    ugh... found the bug:

    void* get_lcd_422_buf() { //~ return yuv_422_buffers[0]; return get_yuv422buffer(0); }

    from nanomad's new buffer detection... this branch was merged with main and yet it doesn't look like it from the source.

    For the intervalometer bug I think adding one of those ensure_qr_modes to the right place will fix it.

  4. One Percent

    It looked merged but actually the commit said merge unified into it.

    Actually besides these 2 bugs I haven't found anything else wrong with it.

  5. Former user Account Deleted

    Hey, so I tried this again after not updating the Nightlys for quite a while and it's still there.

    I activated AB and then just pressed the shutter button all the way down (no halfshutter, no wait for focus). The DSLR skips the 2 second delay and starts to take pictures forever immediately.

  6. Former user Account Deleted

    Bug is still present. Jam down the shutter button without waiting for AF and it takes pictures forever. You probably have to give it some trys

  7. Log in to comment