Aperture Control Unstable

Issue #1921 invalid
Douglas Bischoff created an issue

[7D] ONLY

The display for aperture (i.e. f/2.8) disappears and then re-appears on the LV screen. In the menu system, the Aperture menu item under Expo turns itself off then on, presumably a symptom of the same problem.

If exposure override is turned on, there doesn't appear to be any change to the image. If exposure override is OFF, the image changes brightness then back, again presumably a symptom of this issue.

ML Nightly.2014Mar25.7D203

Comments (21)

  1. Douglas Bischoff reporter

    Additional information: I noticed quite by accident that during this same flicker in the "Focus" menu the first four menu items (Trap Focus, Follow Focus, Focus End Point, and Rack Focus) all blink on, then off. In the bottom of the window, "Hyperfocal" changes from 65m (for this particular lens) to "unknown" to the "infinite" symbol. The "Lens" reporting for this fixed, manual-focus lens shows "50-50mm, 50mm f/2.0" normally (correct) and flickers to f/0.0 and 0mm.

    There doesn't seem to be any pattern or correlation between these: sometimes one will change and not the others, etc.

  2. Douglas Bischoff reporter

    Still more information: the problem appears to be related to using Dandelion-chipped manual lenses. Does not occur on a Canon lens.

    Seems possible that the refresh rate of data coming from the Dandelion is slower than that of a Canon chip. Is it possible to ignore "suddenly disappeared" data for a short period, holding previous settings?

  3. One Percent

    your expo shouldn't change when the fake aperture changes in LV with expo override, this is correct. Also you may be losing contact with the chip, same adapter on both cameras?

  4. Douglas Bischoff reporter

    Good questions, 1%:

    To test it, I tried the same lens on a T2i both with "stable" ML build and current nightly. NEITHER exhibited this problem.

    Same lens on a 7D with most recent nightly has the problem of lens information of random kinds being "lost" then "re-found." I've edited the description to make it a 7D-only problem.

  5. Douglas Bischoff reporter

    "Found" is too strong a word. What I'm investigating is how ML is handling rpc calls. Most specifically that the calls to the slave processor all include "wait" loops of 50ms or even 200ms. The issues that I'm seeing (this and the "tearing" problem in raw recording when an HDMI monitor is attached) seem to suggest that there are timing problems between the chips.

    I want to explore whether there's a better way to manage traffic between the threads than wait loops and the ml_rpc_readmem's admittedly bad performance copying. If the buffer CHANGES while ml_rpc_readmem is copying it (such as would explain the tearing issue) that would result in corrupt data.

    The other possibility is that the ml_rpc_readmem or other inter-processor traffic is resulting in a race condition (reading lens parameters that another thread is writing to, for example) or perhaps a dropped message between processors.

    Does any of this make sense to pursue?

  6. One Percent

    heh, i have the same adapter (fixed f/2) and I glued it myself too. Nothing flickers here. Not in photo mode, or video mode, with and without expo override.

  7. Douglas Bischoff reporter

    I'll research how to do that.

    To be clear, the exact same lenses do NOT exhibit this on a T2i running the same nightly build, so it's either something with my camera (a possibility, I suppose) or the 7D code.

  8. Douglas Bischoff reporter

    Aha.... with a modern lens set to manual focus I get a steady focus rectangle. Switch to auto-focus and it changes to a square. Put a Dandelion chipped lens on and it flickers back & forth.

    Tested same configuration on my T2i with no flickering.

  9. One Percent

    so something is wrong with your contacts or the adapter. this is a pretty major issue so if it was happening to everyone I bet there would be more complaints. both pre made and self glued nikon adapters don't flicker for me on 7D and others. The 6D actually won't take the self glued "dandelion" style adapter, it doesn't fit. the ready made adjustable adapter fits on both FF and APS-C but adjusting the aperture changes the expo sim

  10. Alex

    There may be some differences in the communication protocol (the chip uses a reverse engineered version that may not match Canon's one perfectly). I have a no-name chip that works fine on most cameras, except 5D3 - there it gets out of Canon menu and does some other weird things (without ML running). I've removed it from the lens though.

  11. Log in to comment