5D2: Interval + liveview + Powersave

Issue #1969 resolved
Former user created an issue

If putting on interval (say 1 min) with liveview on, then go to powersave and turn off display after 5 seconds. The display willl then turn off after 5 seconds, but then it will turn on again within 5 sec to show the modul console semi-transparent.

Within liveview I can't make powersave to work at all - it only shows the modulconsole. No difference if changing to silent pic.

Workaround: The only way take timelapse with power save is to exit liveview. To get rid of the console you then have to turn it "on" and then "off".

Build: 23 April Camera: 5Dmk2

Comments (11)

  1. Joakim Poromaa

    ML ASSERT: lv at ../../src/zebra.c:4175 (idle_display_dim), task cls_task lv:0 mode:3

    Magic Lantern version : Nightly.2014Apr23.5D2212 Mercurial changeset : 107bde4783a9 (unified) tip Built on 2014-04-22 22:10:20 UTC by jenkins@magiclantern.fm. Free Memory : 122K + 3963K

  2. Joakim Poromaa

    I can confirm that it is now solved. However I got the module console at one point when testing ramping focus + silent pic + 3 sec interval (a bit stressing it I guess). Here:

    ML ASSERT: lv at ../../src/raw.c:1752 (raw_lv_request), task shoot_task lv:0 mode:3

    Magic Lantern version : Nightly.2014Apr24.5D2212 Mercurial changeset : 2a9dc0e15500 (unified) tip Built on 2014-04-24 10:18:20 UTC by jenkins@magiclantern.fm. Free Memory : 129K + 4110K

    I can test some more to come up with a way to repeat this error (I guess this is something else).

  3. Log in to comment