Speedlight Controls not working on 6D

Issue #1997 open
David Stembridge created an issue

Using build Nightly.2014.May20.6D113

When putting my 580EX II on my 6D, I am not getting the External Speedlight Control menus for : - E-TTL II meter - Flash Sync speed in AV mode - Flash function settings (the one I really want)

I first noticed this when using my Yougnuo YN-622c triggers, and then decided to check it out with the flash alone. It does fire; but not everytime. Batteries are fully charged.

Comments (14)

  1. Alex

    So, with ML is not working, and without ML (booting from a fresh card) it's OK? Can you reproduce it clearly?

    If it's OK without ML, try holding SET at startup to disable ML. Results?

  2. David Stembridge reporter

    Okay, I tried that, it isn't working w/o ML. Earlier I reverted back to stock firmware v114 as a test. It was working fine. When I went back to ML on 113, it isn't working. I had a photo shoot this past week, using the same nightly build, and it was working fine.

  3. Alex

    If it doesn't work without ML, there's nothing I can do.

    Clear camera settings, clean the contacts... not sure what else to suggest.

  4. David Stembridge reporter

    My 270EX II on the camera allows me to enable the flash when on the camera with ML disabled. With ML active, I can't do this. I think this is ML.

  5. David Stembridge reporter

    Both flashes give me control of the External Speedlight Control menu with ML disabled (holding set while booting)

    Tested multiple times. Works with the YN-622c triggers also. At least I know a workaround for using my flashes now. ML critical for filming; but not so much for portraits where I need to control multiple flashes!

    One additional note, after typing the note above, camera went to standby; and then I couldn't access External Speedlight Control menu UNLESS I restarted the camera with ML disabled. Very strange.

  6. David Stembridge reporter

    It works without ML. I worked on this for about 2 hours, so my apologies it was a little confusing at first when I identified this. When you hold set down, it only temporarily disables ML. After camera goes into standby, when you "wake it" ML is enabled. The only way I was able to determine the the flash menus were working properly without ML is to insert a fresh formatted card with nothing on it. The flash menu worked as it is supposed to.

  7. Alex
    • changed status to open

    So:

    • with a formatted card, it's OK.
    • with ML, it's not.
    • when you press SET to disable ML, is it OK or not?
  8. David Stembridge reporter

    Correct on 1 and 2. on last one, when hitting SET, it works initially; but as soon as the camera goes to standby, and ML is activated again, it does not work

  9. Alex

    When it goes to standby and wakes up, this is a full restart, so you are going back to case 2. So, the answer to 3 is OK, plain and simple.

    From this point, I can troubleshoot it without a camera in my hands (and hopefully fix it), by sending you test builds to check whether the flash is working or not. Most likely we'll need a weekend for this.

  10. Log in to comment