650d and external flash in LiveView mode

Issue #2081 wontfix
Udo Wolter
created an issue

Hi, someone told me I should add this as bug report, so I'll try:

I bought a Yongnuo flash for my EOS 650d and noticed it does not fire with Liveview. Thank god there's MagicLantern I thought and so I tried ML. I had an older version from march this year on my SD card and I found the flash tweak, where you can use LV flash with non-Canon-flashes and XXXd-cams. What happened was this: I switched on live view, focused with half-pressed shutter. The live view vanished and I can press the shutter completely. The picture will be shot but no flash was firing. Afterwards nothing happened, the menu was frozen I couldn't do anything, just switching off the camera, everything else was blocked. After switching on it seemed half of the battery power had been gone in this operation. The picture was there but because of the missing flash fire too dark. Ok, I thought, maybe the build is too old and so I tried the nightly build from August 2nd. But: same problem, no flash, camera hangs.

Thank you! BTW, this is a marvellous firmware, I don't want to miss it anymore! Everytime I'm thinking about buying another cam I just compare the stuff the new camera can do and the stuff ML can do. ML is far up in the sky compared to all of the rest! You did a great job! Bad news for me: I have to stay with canon cams which is not always the cheap side of the world. But it's worth it! Canon should pump money in this project!

Comments (8)

  1. Alex

    Can you (or any other 650D owner) check if the feature is working with internal flash? To my knowledge, nobody ever tested it.

    I've tried on 60D and 500D (internal flash), and it works fine. If nobody confirms it's working on 650D, I'll have no other choice but disabling the feature.

  2. Udo Wolter reporter

    I tried with internal flash:

    It fired, but the result afterwards is the same: camera blocked. Although: after turning the wheel (A, P, Auto, M) it unblocks. What I find strange: normally I'm using half-pressed shutter in LV to focus on an object. But after half-pressing LV goes off and I have the normal non-LV-menu on the display. This means that focussing in this special mode isn't possible?

  3. Mathew Kelly

    By the way, which focus method are you using, did you try all of them to see if you have same results? I know AF Quick is no good for this use, but all other modes are fine.

  4. Udo Wolter reporter

    OK, I tried different things. All of those Focus methods in LV. There was no difference (LV goes off, shooting without focus, cam blocked) in the handling. One thing was different:

    although shooting with the flash directly connected should be the same like shooting with a (non-supported) wireless transmitter it's not. With the wireless transceiver the flash was firing! For me this is sufficient, because those ones are special transmitter, I can also mount the flash on top of it.

    Nevertheless, the strange handling is still there: LV ends, no focus control, shoot, cam blocked. :(

  5. Log in to comment