550/t2i Seems Dead

Issue #211 resolved
Former user created an issue

I installed Canon 1.09 firmware first. Reboot was fine. I installed the magic lantern firmware fine (waited for like 10 seconds after the drive light went dark and the screen went dark). Then I pulled the battery again. Then I rebooted with the SD card and the correct files installed and flags set (verified them and actually tried another card as well). The camera won't even light up at all - no boot attempt - no power lights, nothing. Like it's dead. Doesn't work no matter what battery I put in (I have three) or what SD card (or without a card either). HELP!!!

Comments (18)

  1. Alex

    M-L-Userrr to Magic:

    Is your card bootable ? So did you was in magic lantern menu or did it failed to turn on after you installed magic lantern ?

  2. Former user Account Deleted

    Hey guys, thanks. I did see that screen a1ex, but it was all jumbled up and formatted weird. The screen went dark but the drive light stayed on and I waited until it finally went off and another 10 seconds after that.

    I think the card is bootable - I did it in XP and when I run the utility I downloaded from you guys - it tells me that it's working, I installed magic lantern and then I shut it off. I never tried booting it without the new bootable disk.

    I think the first time I saw a very brief drive light and then nothing. Nothing at all now.

  3. Former user Account Deleted

    No buttons do anything - including menu and display - it is almost like the battery is completely dead but all three are freshly charged.

  4. Alex

    Can you also send to me the LOG file which was created on your card when installing ML? It's a small text file (LOG001.LOG or something like this).

  5. Alex

    It seems OK for me... Magic Lantern started, initialized...

    Indy, do you have an install log to compare it?

  6. Alex

    Does it autofocus? (even with display off)

    On CHDK forum, someone suggests leaving it a long time with the battery out, or maybe even removing the internal CMOS battery (see the 350D thread).

    Another "bricked camera" case was solved by installing ML on another camera, and putting that card back in the first one.

    It didn't hang in the middle of install. As long as it created that log, it already ran all the install code.

    /** Perform an initial install and configuration */
    static void
    initial_install(void)
    {
    	bmp_fill(COLOR_BG, 0, 0, 720, 480);
    	bmp_printf(FONT_LARGE, 0, 30, "Magic Lantern install");
    
    	FILE * f = FIO_CreateFile("B:/ROM0.BIN");
    	if (f != (void*) -1)
    	{
    		bmp_printf(FONT_LARGE, 0, 60, "Writing RAM");
    		FIO_WriteFile(f, (void*) 0xFF010000, 0x900000);
    		FIO_CloseFile(f);
    	}
    
    	bmp_printf(FONT_LARGE, 0, 90, "Setting boot flag");
    	bootdisk_enable();
    
    	//bmp_printf(FONT_LARGE, 0, 120, "Writing boot block");
    	//bootflag_write_bootblock();
    
    	bmp_printf(FONT_LARGE, 0, 150, "Writing boot log");
    	dumpf();                                            // <------  here it creates the log
     
    	bmp_printf(FONT_HUGE, 0, 180, "Done!");
    } 
    
  7. ugacdawg

    It doesn't autofocus or do anything at all. I don't have another camera to do an install on. I would also be inclined to think that wouldn't work because there is no attempt to even access the card at all upon turning on the drive. It's not like it searches for a boot disk and then hangs because the disk isn't right. It does nothing.

    I'm going to RMA it back to Canon to re-install the 1.09 factory firmware. Thanks.

  8. Alex

    Sorry for that. This seems to be the first case of camera damage due to ML.

    Please tell us the final outcome. Thanks.

  9. ugacdawg

    Well, thought you guys might like an update. I sent off the camera to Canon and when I got it back it booted up just fine... into Magic Lantern!

    Yep, apparently whatever they did it didn't involve writing new firmware and it kickstarted what was an apparently successful install of ML after all.

    Go figure.

  10. Alex

    Yay! Did they say what they did? Or they just booted it with their card and it worked?

    P.S. My IBM Thinkpad Service Manual says some intermittent problems are caused by... cosmic radiation :)

  11. Log in to comment