FPS Override (EOSM)

Issue #2122 open
gmr20 created an issue
  1. Problem When using FPS Override to record a video at daytime, EV-3 is still too bright. Not possible to record a video. I only tested FPS=1 or less than 1.

  2. Suggestion When FPS is set to very low, can the video be recorded with a resolution better than 1920x1080? I think it's reasonable (for the hardware) and great feature for a time lapse video. Thanks.

Comments (11)

  1. Christian Chaney
    1. it's not an issue ! You must use an ND filter.
    2. No.

    This is not the place to ask for features but to report issues. Please go to the forum.

  2. Daniel Fort

    Sorry, I didn't know this bug was still valid. I tested the EOSM unified build and recorded video (both H.264 and raw) with FPS=1.

    The user who reported this issue also posted this bug on the forum. Note that he only put up 4 posts and hasn't checked in for several years so I thought this was just an inexperienced user posting an invalid bug report.

    I tried to reproduce the steps from Bilal's video using the EOSM with the crop_rec_4k build from the experiments download page. It does not show the correct shutter speed when using FPS override. It also doesn't have the flickering issue and records H.264 just fine.

  3. Alex

    The crop_rec_4k build from the experiments page doesn't contain the fix; it's not included because I know it's broken, but I wasn't able to fix it properly. I'll probably revert that change and think of some other solution. While I had the 700D, I could confirm that overriding shutter speed from adtg_gui does not break H.264, but I could not figure out why the "classic" method breaks it.

    To reproduce the bug, you need to compile from current crop_rec_4k branch (commit d556a10).

    The overexposure problem at low FPS is valid on many other models, with very few exceptions (only 5D3, 60D, 600D and 1100D implement this properly; the first two were tested by me).

  4. Daniel Fort

    Ok -- "Caveat: fps_override_shutter_blanking is now required." that jogged my memory. We had a discussion on commit 046e388.

    [EDIT] LiveView corruption on the EOSM when changing shutter speed from Canon menu is still an issue with commit d556a10.

  5. Daniel Fort

    Bigger issue on the 700D with commit d556a10.

    700D.jpg

    This is without even turning on FPS override.

    The first bad revision is:
    changeset:   17477:58d67357be15
    branch:      crop_rec_4k
    user:        alex@thinkpad
    date:        Wed Jul 04 19:38:33 2018 +0200
    summary:     700D: enabled FRAME_SHUTTER_BLANKING_READ/WRITE. Does it work?
    
  6. Alex

    That's because these addresses (from that commit) are not fixed on 700D. Need to find some other way to get them.

  7. Daniel Fort

    I see -- so the addresses can change? Is this similar to the Dual ISO issue Bilal pointed out?

    Looking at those registers on my camera:

    700D 805f.jpg 700D 8061.jpg

    Then plugging this into platform/700D.115/consts.h

    #define FRAME_SHUTTER_BLANKING_ZOOM   (*(uint16_t*)0x40452918) // ADTG register 805f
    #define FRAME_SHUTTER_BLANKING_NOZOOM (*(uint16_t*)0x4045291c) // ADTG register 8061
    

    Now it works perfectly on my 700D. (Edit-tried following instructions on commit 046e388 and it might not be perfect with the FPS Override test but it is close.)

  8. Log in to comment