My Canon 700D will not start

Issue #2152 resolved
Former user created an issue

hello,

I have a problem !! my Canon 700D will not start for 4 months, I installed before magic lantern, just before leaving on vacation I format the SD card and when I came on vacation my Canon 700D does not light up.

I look for solutions on the internet and forums to repair my canon 700D but not, I retiter battery, SD card, SD card formatted in low-level format. nothing to do but it will not start.

I count on you to help me do walk again.

kind regards

Valentin (FRANCE)

Comments (15)

  1. Valentin Formont

    Yes the battery is fully charged, I did the same thing with another battery, but nothing START

    In the beginning there was two months the red LED is turned on after inserting the SD card. but now this LED does not light up

  2. Carlos Martín Carrasco

    FIRST, Try another SD, brand new. I've never had magic lantern. You may have activated your SD botflag and has not been taken well !!

    If dont work:
    Try the following and tell me what happens:

    1. Remove the battery, remove the card, insert the battery (CARD NO) and turn on the camera.

    2. Remove the lens, remove the card, remove the battery. Insert the battery and turn on the camera.

    3. Remove the card, remove the battery. Insert the battery, connect the camera to the PC to see if recognized.

    4. Try putting ML another SD card and put it in the camera. then turn it on

    5.- Try

    If you can remove the battery from the camera clock, extract it and try it on.

    How do I stop the camera funcionarte? When? What were you doing? What version are you using magic lantern?

    Have you tried to give all buttons when turned on the camera? Do not do anything at all?

    You may test other battery

    The camera will not turn on if you have the lid of the battery or SD open. Make sure that the tabs have to check that this closed well.

  3. Valentin Formont

    the problem has been solved. the battery was damaged by an electrical problem.

    I try with a new battery every start, but it did not work.

    it did not work because he y'avait no autoexec.bin

    Thank you for your help

  4. Walter Schulz

    If you have the same problem: Change your battery. Or try steps as adviced. If problem persists: Give a detailed description of your problem.

  5. chubby pathak

    What happened is in the following order
    I installed magic lantern some 2minths back. It was working fine but then one day it was causing some problems. While taking photos it will come with a blue screen. Saying a problem has been detected and magic lantern has been shut down to avoid damage to the camara.

    So I went and deleted the magic lantern. Following the steps on how to uninstall ie. By going to updating the firmware and the following the steps to delete. This happened sucessfully. And the camara was working well. But today when I saw the camara it will not start with the spare battery or a newly charged battery. And the red led light is also not blinking. The camara is stone dead.

  6. chubby pathak

    one detail that i did not mention was. i did not formate the card after un-install ML. i still have the AUTOEXEC.BIN.

    Thanks for the help in advance and i sorry for coming of a little scared. and the typing errors.

  7. Walter Schulz

    "Blue screen" was an April' Fools Day Prank and you fall for it.
    Because you uninstalled ML properly about 3 months ago your problem is not related to ML. Contact service and/or seller.

  8. chubby pathak

    oh ok so this is not related to ML i am so relieved. thanks for the help. i will get it replaced then

  9. jdamane

    Hi everyone I need your help my EOS 700D does not power up i tried every thing as show by other users on youtube but it still dead.

  10. Shrsheet

    Hi guys I need a help. After removing magic lantern from my card. Camera is not switching on. Help me

  11. Walter Schulz

    Not reading and not applying warnings in FAQ/User Guide/Install Guide doesn't mean your problem will be handled as a bug.

  12. Log in to comment