1. Trammell Hudson
  2. Magic Lantern
  3. Issues
Issue #216 wontfix

Eye-fi Pro X2 doesn't work

JJG
created an issue

I successfully installed magiclantern-2010Dec20.550d.fw109.iso+menu.alex yesterday on my 550D (nice job!). The firmware works with 2 different SD cards that I tried (after making the cards bootable). The problem is that it doesn't work at all with my Eye-fi Pro X2 cards. I have tried both bootable (with the autoexec.bin file on the card) and non-bootable. In both cases the 550D doesn't appear to power up - but it does come up partially... Interesting - no screen, black, pressing DISP, Menue etc has no effect. But, pressing shutter causes the lens to autofocus! No picture is taken. I need to remove and reinsert the battery to get back to normal. One more question - is there a version/varient of the magiclantern.fir file that undoes the camera changes - in other words, resets the BOOTDISK flag in nvram. I want to try from scartch again (and also attempt to get my Eye-Fi back!!!).

Thanks!

Comments (40)

  1. Alex

    Use EOS utility to remove the boot strins from the eye fi card, or try to format it. You should be able to start the camera without ML.

  2. JJG reporter
    • changed status to open

    Thanks, I tried both... neither allows the Eye-fi card to function. I double checked the boot flags on the card (all off) and also did a reformat (using Fat32). At this point, this Eye-fi card will not work with the camera. Does anyone have a way to reset the nvram settings in the camera (back to the pre-magiclantern.fir settings)? It's not that I don't want to use ML, but I want to be able to use my Eye-fi card "most" of the time, then enable ML for more specialized work!

  3. Alex

    Put this in magic.cfg to reset the DISKBOOT flag from the camera:

    magic.disable_bootdiskf = 1
    

    You may also try to format the eyefi card from the camera.

  4. JJG reporter
    • changed status to new

    a1ex - thanks - that did the trick. I can run either Eye-fi with no ML or enable ML and use a different SD card. I tried to redo everything from scratch. The Eye-fi worked once!!! But then stopped after another cycle...

  5. Anonymous

    I'm having troubles with this at the moment. I had Magic Lantern installed on one memory card, but then decided to get rid of it, so formatted the card. A few weeks ago I bought an Eye-Fi card which did what JJD's did on his. Camera seemed dead apart from auto-focus. So I figured out from reading a few posts that the solution is to disable the bootflag on the camera which I have no idea how to do. Any would be muchly appreciated!

  6. Alex

    If the camera seems dead, but it does autofocus, it means the card is bootable, so try to put an autoexec.bin on it and then format it from the camera.

    I don't know if formatting from PC removes the bootflags, but you may try (not quick format).

  7. Anonymous

    I tried it with an autoexec.bin, but the camera would still not do anything other than autofocus, which means I can't format it that way. I'll try formatting it from a PC as I've only tried from my mac.

    But formatting the card wont reverse the bootflag on the camera, will it?

  8. Anonymous

    Hi,

    What I did was get another SD card, enabled the boot and put the autoexec.bin file AND I also put a magic.cfg file on the card with the following line:

    magic.disable_bootdiskf = 1

    This is the bit of magic that has Magic Lantern reset the boot flag in the NVRAM.

    You will see Magic Lantern boot up, parse the config file, then reset the bootflag on the camera.

    You cannot use the Eye-fi card to do this....

    I hope Eye-fi and/or Cannon get this working!!!!

    Good luck jjg

  9. Anonymous

    Tried putting magic.disable_bootdiskf = 1 in the cfg file, but for some reason it just boots up magic lantern as it normally does and there's no indication that the bootflag was reset?

  10. JJG reporter

    Hmm, do you see the message on the startup screen that it parsed the config file?

    This has always worked for me. In fact, I have a small SD card that I use to reset the bootflag whenever I want to insert my Eye-fi card. It resets fine, I use the Eye-fi card, then when I want to take advantage of the great ML features, I have another small SD card with the file that sets the flag back to enable.

  11. Anonymous

    Hello, I have the same problem. I putted in magic.cfg magic.disable_bootdiskf = 1 Magic Lantern starts, and prompts: Config file parsed, But the camera is still booting Magic Lantern and the Eye-Fi-Card is dead. Has anybody found a sollution for this? Thanks

  12. Anonymous

    Hi, I've done everything suggested here but nothing will make the Eye-Fi card work again in my T2i. I have one SD card that runs ML, another SD card that runs ML with the modified magic.cfg file (with "magic.disable_bootdiskf = 1" as the last line), another SD card that has runs normally with no boot flags and no ML, and then my Eye-Fi card.

    The other SD cards work with and without ML, but none of the above suggestion have been able to get the Eye-Fi card working again.

    1. I've low-level formatted the card in another canon camera (S90), there is no data on the card. 2. I've disabled the "Eye-Fi Center" software on my computer, which "initializes" (i.e. writes some data to) the card each time it's inserted. 3. I've used EOSCard to remove any boot flags, and the camera still doesn't boot with the Eye-Fi card. 4. I've used EOSCard to put the ML boot flags on the Eye-Fi card, along with the other ML files, but the camera still will not boot (blank screen with autofocus). 5. I've also used EOSCard to set the boot flag to EOS_DIGITAL, which is the boot flag set by an in-camera format, and nothing will work. 6. I've also tried using the SD card with "magic.disable_bootdiskf = 1" before all of the above steps (except the one where I tried running ML from the card).

    I need the Eye-Fi card more than ML, so I need to revert the camera to the original state (when the Eye-Fi card would work). The "magic.disable_bootdiskf = 1" line in the magic.cfg does NOT return the camera to its original state. If it did, then I would have to rerun the magiclantern.fir in order to get the ML cards to boot, which isn't the case, since the ML cards boot fine no matter how many times I've run the "magic.disable_bootdiskf = 1" card. Also, if the camera were in its original state, the Eye-Fi card would work, and it does not.

    Please tell me how to return the camera to its original state. What will happen if I reinstall the original Canon 1.0.9 firmware (will the camera even let me do this)?

    Thanks for any help you can give, CBB

  13. Anonymous

    Just a heads up, I have seen the same problem on the 60D -- I would love to know how to reset this, as now my eye-fi card is useless.

  14. Alex

    When you boot ML with magic.disable_bootdiskf=1, do you see this message on the screen?

    **disable_bootdiskf**
    

    If not, post the config file here.

  15. Anonymous

    a1ex, thanks for your response.

    No, I do not see **disable_bootdiskf** when I boot with "magic.disable_bootdiskf=1 in the magic.cfg file. I have pasted the contents of my magic.cfg file below.

    crop.file.1 = B:/hd_ta.bmp
    crop.file.2 = B:/CineScop.bmp
    crop.file.3 = B:/fish8r.bmp
    h264.qscale.min.neg = 16
    h264.qscale.max.neg = 1
    zebra.delay = 1000
    magic.disable_bootdiskf = 1
    
  16. Colin Peart

    Same here - I was about to dump the config file here, but that's what I see. Probably because it is the default config file with just that one line added to it.

  17. Colin Peart

    Here are some logs. the things I can see in them are: -magic.disable_bootf is indeed 1 -the dump task is run, which is where the disable_bootf flag is checked.

    I didn't see the message that debug.c should have printed indicating that it was running that command. Granted, it could have gone away really quickly, as well. I don't yet have a compilation environment set up, but I am heading in that direction shortly to see if I can find anything.

    As you might have guessed, this was run with a non-eyefi card. I hope we can figure out how to reset that part of the camera so eyefi cards will work without crashing the camera. And in the long run, I am looking forward to having access to magic lantern on my 60d -- but once I get it reset and working for my eye-fi card, I may leave it for a while. Maybe let other people put their camera at risk for a while, until it's more mature.

  18. Anonymous

    Thanks for the link to the prerelease, a1ex. This solved the problem for my T2i. Here's the step-by-step:

    1. Downloaded the prerelease build from a1ex's link above. 2. Took my current ML SD card and erased the contents, using Windows explorer, just in case that's relevant (left the boot flags intact) 3. Copied the prerelease .bin, .bmp, and the .cfg files to the SD card. 4. Put the card in the T2i and turned the camera on. 5. Pressed the "delete" key to launch the ML menu. 6. Navigated to the "Boot" section of the menu. 7. Navigated to the "Autoboot" option and pressed the "Set" key to toggle the option to "Off" 8. Turned off the camera and removed the SD card. 9. Inserted my Eye-Fi X2 card, turned on the camera, and voila! It works.

    After this, I formatted the ML SD card in my computer, as I will not be using it any longer. If you still wanted to use ML, I'm not sure what steps you'd take to get the ML card to boot again (other than running the initial ML .fir again).

    That's the full report. Hope this info is useful to others.

    --Collin

  19. Colin Peart

    I managed to get my camera (60d) working again in it's stock configuration as well.

    It looks like the 60d build of the software is not handling the magic.disable_diskbootf flag properly. To fix mine, I had to get the toolchain built, and rebuild based on hg clone ... -r 60D. I had to edit debug.c and remove the condition

    if (disable_bootdiskf!=0) {...

    on or about line 644. Basically, I made it so that it always calls the function to reset that flag.

    So, now my camera is back to it's old self. I will have to follow this project more and wait for something that has had more time to sort out the issues.

  20. Anonymous

    For all the T1i users out there...

    Try one of the earlier PreAlpha builds as a1ex suggests. It should give you the option to turn the autoboot feature off in the menu.

    (FYI: Adding the command line never worked for me either.)

  21. Anonymous

    hmm, any suggestions on what we should do to get ML back? =( Using the pre-alpha build, it was pretty easy to turn autoboot off, but now ML won't boot to get back to that setting to turn autoboot back on!

    from the wiki: "DO NOT repeat the firmware upgrade step with magiclantern.fir! There may be a firmware update counter like on the 7D, and you may end up with a bricked camera."

  22. Anonymous

    i need help when i remove magic lantern the internal mic doesnt record sound any sugestions on how to fix this?

  23. Anonymous

    i'm using nikon d90 and canon 550d, is there any problem if i use the card i used to instal magic lantern in 550d in my d90 also?

  24. Anonymous

    I experienced the same problem on the 550D/T2i. Here is how I got the eye-fi card working.

    Insert a card with Magic Lantern installed on it. Hit MENU on the camera and navigate to the firmware update. Select Firmware Ver. 1.0.9-ml-2011Oct21. (or whatever version it will say for you) as though you are initiating a new firmware update. Hit OK. Wait while ML loads. If you read the green text it says to disable the BOOTDISK switch the shooting mode from the mode dial to anything *other* than (P/TV/Av/M). I switched it to [CA]. White text appears saying BOOKDISK is disabled. Switch off camera. Switch camera on. ML does not load. ML is now uninstalled from your camera. To get the EYE-FI working:

    Switch camera off. Insert Eye-Fi card. Switch on camera. Take a picture. You will think the display is not working, after a few seconds the display comes on and camera back to normal. Camera should be stable from now on.

    To re-use ML. Switch off camera. Insert SD card with ML on it (the card you used above). Navigate in the Menu system to the firmware update. Hit Firmware Update. Press OK and install ML. ML will install. Reboot camera. ML now installed. Use the above process to get back to using Eye-Fi card.

  25. mikeokeefe

    Hi, I have a Canon 60D which I had used with Magic Lantern in the past. I recieved a Eye-Fi x2 pro for Christmas and found it would not work in my camera. This post is to explain to others like me how I got my Eye-fi card to work.

    To get your camera to boot with an eye-fi card in it you need to uninstall magic lantern AND reset the bootflagf variable in your cameras ram to default. If you read above there was a way to set this variable with a config file but that method no longer works in the current versions of ML. There is however a new way. This might be stating the obvious but I had a few problems because I read on the Magic Lantern website FAQ that said "There is no need to "uninstall" [magic lantern] -- simply format your card to reboot to the stock Canon firmware." This is not entirely accurate, if you do that you will remove the ML software, but that bootflagf variable will still be modified in your cameras memory. What you need to do is follow what the instructions on removing ML from your camera as stated in the UserGuide.pdf (included in the ML download) which says and "Disable the bootflag (this will uninstall ML from the camera; to do this, run Firmware Upgrade and follow the instructions)." It precedes that by saying you need to format your SD card to remove the ML files, you don't need to do that if you don't want to remove the files (ie if you want to keep ML on the card for later).

    SO, long story short, this is what I do when I want to stop using Magic Lantern and start using my Eye-fi card on stock camera settings.

    1. Uninstall ML by running the firmware upgrade again. When you get to the green screen follow the instructions and rotate camera mode selector knob from M or whatever mode you're in to Automatic (Green Square). This step disables the bootflagf variable on your camera which allows your eye-fi card to work. No need to format your SD card with the ML files on it.
    2. Turn your camera off. Swap out your "Magic Lantern" SD card and install your eye-fi card.
    3. Turn your camera on. Clear the user settings as instructed previously by the ML uninstaller screen. I've found that if I don't do this my camera behaved weirdly so make sure you do it.
    4. There is now a new Eye-fi setting on your camera's menu. You have to find that setting now and "enable" your eye-fi card. That's it, you should be good to go. Eye-fi also recommends that you format the eye-fi card but I don't do it every time and have had no problems.

    5. If later you want to use Magic Lantern again just swap the cards again and re-install ML to your camera as you've always done.

    Kind of a pain but that's how I'm using both Magic Lantern and my Eye-fi card.

    -MIke

  26. Elias_Gourvelos

    As above with #34 (hope its the correct number) I found exactly the same sequence / method and was about to post it here as a work around to get the 550d to enable the Eye-Fi card to function again. I dont mind having to re-install the ML firmware but I am still trying to get it to function with the Eye-Fi card with ML firmware installed has been a challenge no variant at this point work. Attempted Boot disk non boot disk, reloading original firmware and various combinations but still nothing, low level formatting and so forth makes no difference.

  27. Log in to comment