[550D] Pressing menu button 3 times causes camera to freeze

Issue #217 resolved
Former user created an issue

I have noticed this in the latest build for 1.0.9.

When I press the menu button 3 times (6 times if 550D is set to show display), the screen will go off and refuse to go back on. 90% of the time I can take pictures (with no screen), but sometimes an error 80 comes up. I have to take out the batteries in order to make it work again.

Comments (19)

  1. Former user Account Deleted

    Start in video mode, wait for ML init, press menu button 7 times - camera just freeze. The same in photo mode. Without ML just fine.

  2. Former user Account Deleted

    It works fine without ML, but it happens regardless what mode I'm on when ML is loaded.

    Main menu appearing 3 times causes it to crash or the display to not go back on, regardless if done slow or fast. It's always 3 times, never more. Everything else works fine once I don't go into the menu.

    I tried all builds for 1.0.9 and the same problem appears on all of them.

  3. Former user Account Deleted

    I could try a different SD card and report back. Current SD card is a sandisk videoHD 16GB, class 6.

  4. Former user Account Deleted

    Hmm, works fine after I formatted through windows instead of formatting on camera. FAT/FAT32, default allocation size option and then rechecked flags on EOScard.

  5. Former user Account Deleted

    Nevermind, works on Lexar card now but does not work on Sandisk. Perhaps it's because it's over 8GB?

  6. Former user Account Deleted

    Ultimate solution, worked with Sandisk 8GB too! Just do a little of dd if=/dev/zero of=/dev/(sd reader) and format in *Windows* + EOScard boot flag. WORKED!

  7. Former user Account Deleted

    It seems to be just temperamental with certain SD cards, ie. Sandisk. Has anyone got it working with 16GB+ cards?

  8. Former user Account Deleted

    Another update - "ultimate solution" don't work anymore. On first boot fine, but take picture & reboot - it starting to fails again. WTF?

  9. Former user Account Deleted

    Having the same problem using 8GB Sandisk Extreme Class 10, other SD cards seem to work fine. I've tried a Transcend 16GB and Patriot 16GB, both class 6.

  10. Log in to comment