5D MK III will not accept ML

Issue #2172 resolved
Vince Duperron created an issue

My 5D MK III had magic lantern on it and I wanted to update it. I formatted the SD Card and put the latest download for FW123 on it ( magiclantern-Nightly.2014Aug07.5D3123.zip ). I asked the camera to do a firmware update. The camera accepted the command, briefly tried to load the firmware and went dark.

The instructions say to update the camera, even if it already has the latest firmware, so I downloaded the latest 5D MKIII software from Canon (also 1.2.3: EOS 5D Mark III Firmware Version 1.2.3 [Mac OS X] ) dated 10/30/2013. The camera readily used this image and updated its firmware. I tried again with the ML firmware and failed. Same as above.

I tried a couple versions back, same as above.

I tried the version I had originally had on the camera, also failed.

I tried a different SD-Card, failed.

I have tried about 30 times to load the firmware. I successfully loaded the Canon firmware twice and the ML firmware zero times. I tried low level formats (per instructions) and tried using Apple's Disk Utility to format the disk. The ML firmware will not load.

Comments (2)

  1. Vince Duperron reporter

    After filing this bug I believe I resolved the issue. It is necessary to remove the Compact Flash card and leave only the SD Card with the ML firmware in the camera. The install proceeded normally after I removed the Compact Flash card and tried again.

  2. Log in to comment