5D3 1.2.3 Not commingmout of sleep

Issue #2355 resolved
Former user created an issue

Loaded ML nightly build and have issues waking up from sleep. Shutter nor power would wake it up. Only thing that worked was removing the battery. After about 5 times, even battery removal didn't work. Had to remove the internal battery to get it powered on. Currently ML is uninstalled.....

Comments (5)

  1. Walter Schulz

    Internal battery is just clock battery and doesn't change any other camera setting. Healing by removing this one is urban myth. Replace you "normal" battery. Might be going rogue. No ML issue.

  2. Jack Smith

    How are you so sure? Should not be so dismissive of my bug report.

    "Internal battery is just clock battery and doesn't change any other camera setting.".....well, the "normal" battery doesn't change any other "camera setting" either. Perhaps, just like the "normal" battery resetting some functional elements of the camera when it's pulled, the "clock" battery also resets something to get it out of an unresponsive state......Clock? Volatile memory?.

    My batteries are not bad. The batteries and camera are relatively new! I have 4 "normal" batteries that I used. I don't think all 4 can't be bad....

    When it locked up, I replaced the battery with different ones, not the same one. Like I said, it worked for about 5 times but then replacing the battery stopped working., I tried all 4 of them, many times over. This problem happened immediately after I installed ML, over the course of 2 hours. As soon as I was able to recover the camera, I uninstalled ML.

    Again, my batteries are not bad. Camera and batteries are relatively new!

    Luckly, I was able to find advise from one of the thread located on this very forum and recover my camera. At least two people were able to recover their camera from a "bricked" state to a functional state by removing the internal battery. Again, you should not be so dismissive.

    Just because the problem can't be correlated to something obvious does not make this issue inconsequential, a non-issue or an "urban myth". After all, this is a bug report.

    Is it a ML issue? After removing ML from my camera, I can wake It up normally, without resorting to pulling batteries every time it went to sleep.

    So YES, absolutely a ML issue.

    One additional detail for those who can help. If I pressed the shutter button soon after my 5D3 went to sleep (<5s), it would wake up. If I tried to wake up the camera after a certain period (<5m), it wouldn't respond so I had to remove/replace the batteries. The instance when nothing worked, other than pulling the internal battery, was the longest period between the time it went to sleep and I tried to turn it back on (-15m). These times are approximate. The problem happened continuously until I removed the internal battery to power it back on in order to remove ML from my camera.

  3. Walter Schulz

    Normal battery removal will stop camera from running ML and canon code. No power -> No tasks running. That's why people having hanging cameras should do so. Sorry, but you should provide links about people able to unbrick by pulling clock battery. According to a1ex (you may call him Dr. Unbrick) this is just a myth. http://magiclantern.fm/forum/index.php?topic=12771.msg123179#msg123179 "The small battery only keeps the clock, no point in removing it."

    The only thing changed inside the cam by "installing/uninstalling" ML is camera bootflag. If set cam will look into card and - if bootable card is found - will try to locate Autoexec.bin.

    You haven't by any chance tried to use Eye-Fi card with cam's bootflag enabled? This will in fact block the cam starting if bootflag is set.

  4. Jack Smith

    It took a while for me to locate the thread I was referring to for some reason but here it is, http://www.magiclantern.fm/forum/index.php?topic=11522.msg112030
    I realize it may or may not be for the same reason, but the effect and the results are the same.

    As you can see from the response, ds.trais said "Thanks Walter, this worked!"...that makes at least 2 people, ds.trais and myself :)

    With all due respect, considering your highly valued contribution to ML, I am a little confused as to why you are calling your recommendation a myth (if you are the same Walter Schulz as the person on the thread).

    Whatever the reason, the recommendation WORKED for me and saved me from tremendous amount of stress. Thank you!

    I was really stressed out because the camera would not turn on, no matter what I did; took out all the cards, took out main battery, waited a while replaced battery w/wo card!

    One thing I didn't follow from your recommendation was to wait for at least "half an hour". I couldn't wait that long! I actually waited less than 5 minutes before reinserting the clock battery. After I reinserted the clock battery, with the cards out, I was able to immediately turn the camera back on.....

    Your question regarding Eye-Fi...yes, I have Eye-Fi but didn't put ML on that card. I put ML on the CF card (actually a SD card with a CF adapter). I had no trouble with it running, only when it went to sleep longer than a certain period of time (I don't know what that time period is)...

    Thanks

  5. Log in to comment