Issue #2381 resolved
Daniel created an issue

Here are some crashlogs which I shall "send to ML devs" from my 700D.

Comments (16)

  1. Daniel reporter

    Yeah it's mostly just from daily use. I've already got used to the regular crashes. Shall I note what I'm doing everytime when it crashes? I thought that's written in the logs... Sigh that'll become quite much paper.... (Someone should implement the notebook feature.)

  2. Alex

    Some of these errors are related to PROP_STROBO_REDEYE and PROP_STROBO_SETTING, which seem to be triggered from debug_task. In ML source code, there is nothing that touches these two properties. This does not appear to be the regular ML nightly build - where you download it from?

    [SOLVED] Another one is PROP_PICSTYLE_OF_USERDEF1. This is indeed a bug in ML, but I don't know what to do, other than disabling picture style features. This seems to affect 650D as well. Cc @nikfreak - can you change picture style settings from ML on 70D/100D?

    [SOLVED] Another one: ML ASSERT: buf[0] == 1 || buf[0] == 5 || buf[0] == 10 at ../../src/shoot.c:690 (_prop_handler_PROP_LV_DISPSIZE), task PropMgr

    Does the 700D has some more zoom settings, besides the usual x5 and x10?

    Many other asserts seem to indicate real ML bugs - can you try to reproduce them?

    For example:

    • ASSERT: FALSE at ./Memory/Memory.c:187, task MetaCtg
    • ASSERT: 0 at Graphics.c:3580, task CtrlSrv
    • ASSERT: 0 at ./KernelDry/KerSem.c:306, task shoot_task
    • ML ASSERT: lv at ../../src/raw.c:1690 (raw_lv_request), task livev_hiprio_task

    I can't tell what those are without info on how to reproduce them, sorry.

  3. Daniel reporter

    Thank you very much for your time, Alex!

    So, ehm the PROP_STROBO_REDEYE & co was when I desperatly tried to turn on the AF-lamp somehow... After some hours I got that only the AF-light option is being turned on in settings, then I gave up. (If you could provide a snippet how to do it I would be really happy btw)

    Does the 700D has some more zoom settings, besides the usual x5 and x10?

    No I don't think so, but it has a touch screen were you are able to move the rectangle to where you want to zoom after the first button press, maybe that makes some difference?

    Many other asserts seem to indicate real ML bugs - can you try to reproduce them?

    Yep I'll try to. I think the "ASSERT: FALSE at ./Memory/Memory.c:187, task MetaCtg" occured when you did something with some settings and then pressed the LV button before ML is completely initialized... Not sure, I'll try to figure it out.

    BTW there are 6 more crashlogs still on my cam from my vacation.... Probaly the same issues.

  4. Alex

    Ah, understood. Back then, I was able to turn the AF lamp on 550D, and the code should still be in the commit history (here).

    edit: sorry, misunderstood the picture style bug; the crash probably happens only if you change settings in the Auto picture style.

  5. Daniel reporter

    So, here the other crashlogs are. It's mainly just ASSERT: FALSE at ./Memory/Memory.c:187, task MetaCtg and one time ML ASSERT: lv at ../../src/raw.c:1690 (raw_lv_request), task livev_hiprio_task

  6. Daniel reporter

    Well the zoom fix seems to work, I didn't manage to produce any error anymore. Even the zoom-on-turning-focus-ring option works now. Really great!

    VRAM0.PPM.JPG

    The picture style thing seems to work fine now, both setting and seeing the values. Even if it's an auto picture style.

    EDIT: Well the recording picture style doesn't work for the first movie being recorded since camera start but that's already a known issue.

  7. Daniel reporter

    Uh, I've got 35 new ones (Crashlogs, and one ASSERT) on my cam. It's impossible to always note what I did before. I just always want to get the shoot done.

    However, 33 of the new crashes are those at ./Memory/Memory.c:187, task CtrlSrv, and I noticed that they mostly appear when I start doing things really really quickly after switching the camera on, before everything is loaded, or when doing other "bigger" tasks suddenly after some ML stuff. It seems to be mostly things like switching to movie mode, enabling liveview, playing back a video. However, it's hard to reproduce willingly (for some reason) so take it as an assumption.

    Also, there are like 95% less crashes when disabling lua, probably because it takes aaaggeees until lua is loaded and it therefore is a larger time span in which the camera is in an unusual heavily loaded state where crashes do occur more often.

    So maybe it's some memory related stuff....? Hm.

    If you don't wanna investigate and/or there's too little information, just close the issue.

  8. Daniel reporter

    If you send me a card reader, a compiled build to test and a laptop I can do it as soon as it all arrives ;) No, j/k, I'll try it out when I'm done with my internship, would be nice if it works, thanks in advance.

  9. Daniel reporter

    Uh, never got to test umm_malloc, but I think it got merged, and tbh I haven't experienced any crashes since that, so nice work and lets finally close this.

  10. Log in to comment